Some hardware does not stop sending data when not moved

Some customers have hardware that has erratic movement when they are not
moving the controller and this causes our mixture sound to constantly play.
Setting a higher deadzone will not work because it’s an axis lever. So once
moved to a new position the deadzone is no help. Any ideas how to fix this or
maybe have a future update with a working solution would be great.

Switch cleaner – or if that fails, replacement hardware…

I’m not sure if the sound playing is continous or one-shot, and the fix would
be similar but vary depending on that. If your package sounds are particularly
vulnerable to this control jitter, you could control your mixture sound
indirectly with LocalVar L:SOUND_MYAIRCRAFT_MIXTURE and write a behaviours XML
component (ASOBO_GT_Update) that remembers the value of the underlying mixture
var when it last triggered the sound (e.g. using an O:PREV_MIXTURE variable,
as this would be local to the component) and only trigger the sound (and
update the O: var) when the lever has moved more than a minimum amount. It
could be a single line of RPN. Alternatively/additionally you could do your
own smoothing by setting the update rate of the component to, say, 20, and on
each update:

L:SOUND_MYAIRCRAFT_MIXTURE = 0.95 * L:SOUND_MYAIRCRAFT_MIXTURE + 0.05 * A:THE_MSFS_MIXTURE_VAR

In RPN, of course. That would have a ~1 second smoothing time constant. MSFS
adding filtering/smoothing to the control input to try and compensate for
faulty controls is problematic as that inevitably adds latency to all usage of
that input and there’s no consensus of how much smoothing or delay should be
added.