[SU11] Changes to input keys definitions?

I’ve noticed some changes in the interpretation of string used to define an
Input key used in the SimConnect_MapInputEventToClientEvent call. Some
examples: “Num5” worked fine in SU10, but in SU11 it returns a Simconnect
Exception, and “VK_NUMPAD5” should be used. However, it only works when
“NumLock” is pressed, while the “Num5” that worked in SU10 worked without
NumLock. “Num8” worked fine in SU10, but it returns an error in SU11 and
“VK_UP” should be used instead, and this works without NumLock, as Num8
before. The same with all the other cursor keys. And there are
inconsistencies, for example VK_NUMPAD7 works without having to press NumLock,
while VK_NUMPAD5 requires NumLock to be active. And, is not very clear if
these definitions matches the ones in Winuser.h. Sometimes they do, like all
the VK_ examples, but in other cases they don’t, for example using “VK_RETURN”
in a definition returns an error, but it works with “ENTER”. It would be
useful if a up to date list of such keys could be published or, at least, some
directions about their assignment rules.

Would like to have some feedback about this.

Hello @virtuali The change is supposed to only remove controls that were
unusable before. I am having a look at the problems you mentioned and will
come back to you when I have an explanation. Regards, Sylvain

Hello @virtuali - There was a mistake on our part with some input strings
being discarded rather than being kept as aliases for retro compatibility. We
have pushed a fix in the upcoming flighting update to address this - “Num_5”
is not an equivalent of “VK_NUMPAD5”, just like “Num_8” corresponds to “VK_UP”
and not “VK_NUMPAD8”. I don’t think there’s an equivalent for VK_NUMPAD5 when
num lock is off (apart from Num_5 when will have reintroduced it). “VK_NUMPAD
0 5” is supposed to be but it doesn’t seem to work at the moment and I’ll
have a look at it. - We have inconsistencies between numpad keys behavior.
Some will return their corresponding key (up, left, etc…), some will keep
returning the keypad event (VK_NUMPAD9 instead of VK_PRIOR for example). I
will run additional tests for this. - Regarding “Enter” not having its VK
counterpart, we will add the alias. Please come back to us when the next
flighting update is available so we can make sure everything is back to
normal. Regards, Sylvain

Thanks, I’ll surely report back with results as soon the next build is up.

Happy to report the keys works as expected in version There’s just
a small thing left to fix, in the Documentation Release notes for SDK 0.20.2,
it says the MapClientEventToSimEvent help page has been updated with the keys
definition, and it links there, but the page it should point to is the one for
MapInputEventToClientEvent, which in fact now contains the usable key strings.

Good to know :slight_smile: @Nocturne to check the doc link.