SU11 : Simconnect Time Events Stop Working

Since SU11 Beta the Time Client Events don’t seem to work when we transmit
them from a managed C# Simconnect client. Definition

   simconnect.MapClientEventToSimEvent(EVENTS.CLOCK_SECONDS_ZERO, "CLOCK_SECONDS_ZERO");
   simconnect.MapClientEventToSimEvent(EVENTS.ZULU_MINUTES_SET, "ZULU_MINUTES_SET");
   simconnect.MapClientEventToSimEvent(EVENTS.ZULU_HOURS_SET, "ZULU_HOURS_SET");
   simconnect.MapClientEventToSimEvent(EVENTS.ZULU_DAY_SET, "ZULU_DAY_SET");
   simconnect.MapClientEventToSimEvent(EVENTS.ZULU_YEAR_SET, "ZULU_YEAR_SET");

Transmit Methods

 simconnect.TransmitClientEvent(0, EVENTS.ZULU_YEAR_SET, (uint)timeModel.ZuluYear, NOTIFICATION_GROUPS.GROUP0, SIMCONNECT_EVENT_FLAG.DEFAULT);
simconnect.TransmitClientEvent(0, EVENTS.ZULU_DAY_SET, (uint)timeModel.ZuluDay, NOTIFICATION_GROUPS.GROUP0, SIMCONNECT_EVENT_FLAG.DEFAULT);
simconnect.TransmitClientEvent(0, EVENTS.ZULU_HOURS_SET, (uint)zuluHours, NOTIFICATION_GROUPS.GROUP0, SIMCONNECT_EVENT_FLAG.DEFAULT);
simconnect.TransmitClientEvent(0, EVENTS.ZULU_MINUTES_SET, (uint)timeModel.ZuluMinutes, NOTIFICATION_GROUPS.GROUP0, SIMCONNECT_EVENT_FLAG.DEFAULT);

I have run exactly the same codebase against SU10 and SU11. It works fine in
SU10 (the time changes) and in SU11 nothing happens. Cheers Gary

Hello @SimfestGary I’ve tried in SU10 and SU11 and everything is working well
for me, here the code i’ve tried with :

SimConnect.MapClientEventToSimEvent(EVENTS.ZULU_MINUTE, "ZULU_MINUTES_SET");
SimConnect.AddClientEventToNotificationGroup(GROUP.GROUP0, EVENTS.ZULU_MINUTE, false);
SimConnect.TransmitClientEvent(0, EVENTS.ZULU_MINUTE, 0, GROUP.GROUP0, SIMCONNECT_EVENT_FLAG.DEFAULT);

Can you see any differences in your code and if yes, try to use mine ? If it’s
still not working can you send me your code
([http://devsupport.flightsimulator.com/t/how-to-report-a-bug-or-
crash/77](https://devsupport.flightsimulator.com/t/how-to-report-a-bug-or-
crash/77)). Best Regards, Yohan