Turboprop thrust decrease after SU7 with legacy tables

After the release of SU7, I noticed that our aircraft can’t hit the published
figures any longer. Before SU7 performance on all altitudes was by-the-book,
but now thrust drops very quickly as speed builds up after takeoff. I also
noticed that the plane takes a while to go from 1710 to 1790ft-lbs of torque
at full power as of SU7. The plane uses legacy tables with data coming from
the factory. Back when implemented (SU4) the data got the engine to work
immediately by the book, without the need for adjustment -a testament to the
legacy tables’ quality. Configuration: clean, 5000lbs weight, 101KIAS climb,
1670ft-lbs of torque at sea level. -–Published performance—

-–Actual performance— Test
conditions: Clear skies, no winds Rate of climb in feet per minute, airspeed

101 knots indicated Altitude Manual Test Difference
Sea level 2200 1450 -30%
5000 2040 1350 -22%
10000 1650 1100 -4%
15000 1280 590 +13%
Takeoff rolls are spot-on. We also checked our glide ratio which is correct,
12:1 as the manual says. Therefore, the clean aircraft is correct in terms of
drag & balance. It is also worth noting that the PC-6 coming with SU7 suffers
from sluggish performance and it also uses the legacy tables system. Planes
that use the scalars from the modern FM work fine. I would appreciate a
response on this topic as release of the aircraft is in 2-3 weeks and we want
to have this sorted and avoid another delay.

Just to clarify one comment there, ‘planes that use the scalars from the
modern FM work fine’ just means that they do not appear to suffer from this
particular problem. The reason we are using the legacy tables is that they are
far more precise in their control and it was possible to achieve a far greater
level of accuracy than with the modern scalars, so using them is not an

Paul above did some changes and improved the plane’s lift, but climb rates
still suffer. We barely gained 50fpm of climb rate and I believe it is clearly
a problem with engine power. I did some tests with the default C208 and our
Kodiak and noticed that both of them are incapable of reaching top speed,
staying about 10KTAS below their top speed. However, the drop of thrust on the
Kodiak (legacy tables) is considerably greater than the 208. Test data taken
at max power, sea level. Thrust measured in pounds.

TAS | Caravan | Kodiak | Porter (ASB)
0 | 1940 | 2150 | 1930
50 | 1930 | 1850 | 1700
100 | 1860 | 1370 | 1430
135 | 1750 | 1120 | 1180
155 | 1330 | 1035 | -
Percent change of thrust

TAS | Caravan | Kodiak | Porter (ASB)
0 | 100% | 100% | 100%
50 | 99.48% | 86.05% | 88.08%
100 | 95.88% | 63.72% | 74.09%
135 | 90.21% | 52.09% | 61.14%
155 | 68.56% | 48.14% | -
It is worth noting that the Caravan is barely able to touch 160KTAS and the
Kodiak can hardly reach 155KTAS, with its top speed at sea level being
166KTAS. A difference of 10 knots down and the behaviour of table-based
aircraft indicates that there is a bug with table implementation that wasn’t
there before. The difference in thrust at 100kts (30% drop compared to the
208) matches the one in our climb rate exactly. Changing the thrust_scalar and
cx don’t seem make a difference, as even an increases of 60% fail to achieve
climbs and top speeds. I also reduced my tables from 14x10 to 13x7 as the SDK
says and still nothing changes. It is worth noting that 14x10 worked fine in
the past and its values seemed not to be ignored. We could increase thrust
efficiency and get more out of the engine, but there are two problems with

  1. Our engine data is correct and we know it with 100% certainty
  2. The data worked before SU7 and we were able to hit our speeds quite closely. So if we adapt our engine to SU7, how do we know we won’t have to do it again with SU8 or 9?