3 Types of Cabin Lights, Issue, Not Dimming

Team Asobo and Flying Raccoon, I have a question. I am trying to do multiple
cabin lights, like the Diamond DA62 and Cessna Caravan have. They have
spotlights, left, right, and main cabin area, all using Type10 Cabin light
system. They use SimVar Index’s 1, 2, and 3 for these. These are the Index’s
in the Systems config/lights section. I am using this system to light up; *
Front Cockpit Spotlights * Rear Passenger Cabin seating area’s * Galley I
tried to duplicate mine as much as possible except that two things occur; *
Cabin lights (Type10 lights) only have on/off, but should have
Potentiometers/Dimmers. The dimmers arent working * The Galley lights arent
working (SimVar Index 3). They work with the rear cabin lights, but do not
work on their own switch I have for them. I tried taking out the Index
identifiers in the Model Interior XML for these three switch templates,
mimicking the way the DA62 is done, and the switches are the same. They
animate, but are not dimming. They work (they light up the front cockpit and
rear cabin area’s, as needed, except they do not dim. Any reason why they
might not be dimming? Many thanks, Bill of the gigantic eyebrows people…
Lionheart Creations

This is one of the versions I have tried.  This is my latest version;
Note, this is from my Interior Model XML;




The above code section is nearly duplicate of the Cessna Caravan except
different knob names, Animation names added, and Index’s removed like the DA62
also doesnt have.

I have the exact same problem with a panel light. When defined as an ambiant
light (type=13), it is dimming but it remains on even if all electricity is
off. If I set type to 12 (glareshield), which is what I want, it acts
correctly with the electrical system but it is not dimming anymore. I noticed
that it depends on the effect file used for this light. I have this problem
when using the standard fx_cockpit_white_bulb effect file, but if I use
one of my custom ones, it works fine. I can’t explain why.

I have noticed my problem comes from the effect file. It is surprising, but it
is true. When I use another effect file, everything works fine. I created a
copy of the fx_cockpit_white_bulb effect file, modified just 1 parameter,
and it works. I hope it can help you.