Are Jetways handled differently in Xbox vs PC?

We are noticing the following problem: Some of our sceneries which suffered
the disappearing Jetways bug in SU5, are now working perfectly fine with SU6,
on PC, but not on Xbox. The Jetways shows up on PC, with both default and Xbox
LOD selection mode. They have 3 LOD levels and they switch normally on PC. On
Xbox, the jetways never shows, regardess if you go close, far, move away from
the airport and back, etc. There is one scenery we made, that has Jetways with
5 LOD levels, and on this scenery, the Jetways work on Xbox too. Are 3 LOD
levels not enough for Jetways on Xbox ? Or, could be something else ? The
scenery that shows Jetways is the largest and with the highest number of
jetways, yet is the only one that works.

Hello. 3 LODs is the minimum in the current implementation, even if we
recommend 4. Your jetways shouldn’t disappear until their size is < 0.5% of
the screen.
Did you try enabling the Xbox LOD selection mode to debug it on PC? If so,
do you have the same behavior?
lods> Regards, Sylvain

Hi Sylvain, yes, as I’ve said in my post, I tried enabling the Xbox LOD
selection mode, and jetways still displays perfectly fine on PC. The only
difference between the sceneries with not-working jetways and the one with
working jetways ( again, on Xbox only, they all work fine on PC ), is the only
one that works has 5 LOD levels, while all the not working ones have 3, so I
was wondering if jetways are different (on Xbox) considering the default Asobo
jetway now has 5 LOD levels ( it used to have less, in older SDKs ). I’ve sent
a version of the scenery with non-working jetways with LOD updated to 5 levels
to our Marketplace contact, asking to report if they work on Xbox, which seems
to be the only way to test this. Would be useful it I sent to you a copy of a
scenery with non-working jetways (on Xbox only ) ?

My bad, I misread your post :confused: And you have the Activate LOD limits
disabled in the debug LOD tool as stated in the doc, right? Of course, send us
your package and we’ll have a look. There shouldn’t be any difference between
Xbox and PC with Xbox mode enabled so there’s definitely a bug here if that’s
the case.

Bumping this, just to be sure you got my private message with the scenery to

Hello. I got it. I’m just very busy at the moment and didn’t have time to have
a look yet.

Hi @virtuali, I just tested your package on Xbox and I was able to see the
jetways. Are you sure you sent the right one? Regards, Sylvain

@FlyingRaccoon, I’ve sent you the version I submitted to the Marketplace, so
it’s in its unencrypted form. I couldn’t possibly check if this is exactly
what has been released on the Marketplace on Xbox. If it was the PC version,
since Jetways, as scenery Simobjects, are not encrypted, I could have
downloaded it from the Marketplace to be sure the files are the correct
version, but since on Xbox there’s no way to access any files, I can’t do
that. Are you testing using the current retail version, or some new build for
SU7 ? Then, perhaps, SU7 has fixed the jetway issue on Xbox too ? I’ll try SU7
tomorrow on Xbox but, I assure you that using the retail SU6 and downloading
the scenery from the Marketplace, shows no jetways, on Xbox only.

@FlyingRaccoon , we managed to test SU7 on Xbox today, and I can confirm the
same scenery I sent you, doesn’t show jetways. The only difference, the copy I
sent you to test is the unencrypted version I submitted to the Marketplace,
the one we tested was downloaded from the Marketplace, so it’s encrypted.
Everything in the scenery works perfectly fine, except jetways.

Ok, will try with the encrypted version. Are you testing with a S or X

XBOX Series X.

Hello @virtuali I was able to witness the problem when getting the package
from the marketplace directly. Doing the ingestion process with the package
you sent me does not cause the problem. Can you confirm the zip archive you
sent me for testing is the exact same you sent to Microsoft for ingestion? If
so, that’s an ingestion issue and we’ll investigate with MS where the process
went wrong. @SFSimsDev I’m still investigating the reason why your package is
behaving differently on Xbox. In case this is the same problem, can you
provide me with the zip archive you sent MS for ingestion? Regards, Asobo /

Yes, I’m 100% sure it’s the same ZIP: to check it, I re-downloaded from the
Files area of my Marketplace Teams channel, and it matches MD5 with the ZIP I
sent you. To provide further information: We had the same problem with our
Zurich scenery: Jetways work on PC (they didn’t in SU5, worked again with
SU6), but not on Xbox. It was of the sceneries which had Jetways in 3 LOD
levels so, I sent a version which is exactly the same, just with 5 LOD levels
for Jetways asking them to be sure to test it on Xbox and, not only they
reported no problems on Xbox but, the update has already been released to the
public, and now it works on Xbox too, even when downloaded from the

/users/11/flyingraccoon.html - Did you see
our links?

Sylvian / @FlyingRaccoon did you get our links / files?