Autopilot and NAV linking to GNS530-430 broken, VOR instruments 180 deg off on SU14 Update

Version: SU/AAU/WU XX -
Frequency: Consistently

Severity: Blocker
Context: What package? In edition or mounted from Community? In main menu or in flight? etc…

  • Asobo GNS530/430 NAV systems; NAV and GPS linking

  • Asobo VOR1 Instrument

  • KAP140 AUTOPILOT functionalities: NAV, GPS, VS and some have HDG issues

  • Trinidad TB21GT

  • Quickie Q200

  • Bellanca Super Viking

  • In-flight

Bug description:
Linking of Autopilots to Asobo GNS530 and 430 NAV screens was broke on the SU14 update. GPS, NAV and VS and some HDG commands were broke, no longer functioning. VOR1 reading 180 degrees off, backwards. This includes XBox. Also, oddly, some peoples screens (GNS-530 and 430) now look like crumpled postage stamps instead of full screen units. They are a cluster of graphics in the top corner of the screens. See screenshot below.

Will this be repaired soon? I have 3 product lines that were broken on this Update.

Repro steps:
Setup a NAV flight, VOR to VOR, GPS flight, etc. Note the functionalities of your AP system. Check VOR1 to see if it is 180 deg backwards. Check GNS screens to see if they show up as a cluster of graphics. Check that Autopilot can hold ALT, can hold HDG, can follow a VOR or GPS course.
It appears that Autopilot ‘might’ have also been damaged, if VS is not working. Even HDG was effected when the SU14 first came out.

My planes effected:

  • Trinidad TB21 GT
  • Quickie Q200
  • Bellanca Super Viking

I used Asobo screens at all times as they were the most solid, never having bugs that I remember. I have never gone with WT as they sometimes launch updates with bugs. This time it has effected Asobo GNS screens, which corrupted/broke functionalities with NAV and AP functions.

I need to know what to do, of if these will be repaired. How do we fix autopilots that use Asobo code?


Bill Ortis
Lionheart Creations

Private attachments: Send a PM to @PrivateContent with the link to this topic and the link to download your content

I just tested the Asobo Cessna 172 Classic with same Autopilot and GNS530 and 430 screen systems. They too are broke. The aircraft will not link VS rates to AP, the ALT lock and ALT setting are not functioning.

In the screenshots you can see various VS and ALT settings are non-functional.

When setting VS, plane continued as though the AP wasnt on. When setting ALT, trying to set VS to take it up to 3,000 feet, nothing seemed to work, nor would it do a ALT HOLD.

Lionheart Creations

So I did a little test. I wanted to see if I deleted the WT version GNS530/430 if things would be fixed. But I cannot delete the WT custom version, only the 1.1.4 version. I deleted that one.
This fixes the Autopilot and it behaves properly. But the Screens crunch up in my Trinidad. The AP in the Cessna 172 classic works again like this with 1.1.4 530 deleted. So 1.1.4 conflicts with the AP system.

I am adding some more data here on testing today. I ended up deleting all Carenado planes and 2 other addons, completely removed all Community files, ran SimStaller which said WT 530 had an issue. I had deleted the standard ‘deleteable’ GNS530/430 system, tested, and AP’s worked. Reinstalling all planes, installing my Trinidad from Marketplace (compiled MS version) and reinstalling the second Version 1.1.4 GNS530/430, my Trinidad Autopilot began functioning. I did not test NAV/GPS linking, but the AP could hold ALT, HDG, and LVL. That was nice, and with screens working. But… Asobo Cessna 172 Classic AP is still not working. No HDG, ALT, etc.

I hope that helps.


Some people who are having problems with the KAP 140 Autopilot and custom autopilots that use the KAP coding, and also the Cessna 172 Asobo version Classic which has the GNS530/430 and KAP 140, when these are malfunctioning, they reload the flight and the AP works. First loadup of the flight, non-functioning AP. Reload flight, all is well.

Some are having ‘no’ problems with KAP 140’s. So this is very odd. What can be causing this?

Team Asobo, is the Cessna 172 Classic AP working ok for you?


Are you sure your official folder is completely clean of all marketplace mods?

1 Like

Since the introduction of the WT GNS530.530, there appears to be some “timing” issues introduced, when operating these GPS systems, especially with the default KAp140.

While they may run fine on a faster PC, with a high frame rate, on slower machines, with lower FPS, there do appear to be issues that are not present on faster machines.

The WT GNS530 JS has now got so BIG ( and complex), that maybe only WT can figure this out, if they care to do so, using a slower test PC.

1 Like

Yes. I renamed the Community folder, and also ran the new SimStaller to check for non-linking of the GNS and KAP, navigation, etc.

Hello 22 Charley,

Interesting thought.

I am running a gaming computer, but with only a GTX 1660 GC, about 4 GB VRAM. I have 32 GB of RAM and Intel 7 chips. It might be struggling with the GNS. Odd that it runs on some computers and not others.

A way to test this is to somehow install the older version GNS and if that runs, then I (for one) would know its the GNS update that is blocking it from running.

And… it was running fine before the update…

Yes, Most developers are going to favor developing on a FAST PC. (Time is money)

But I have to wonder how many (including Asobo & WT), then go on to re-test their products on a MSFS Min Spec PC ??

We (WB-Sim) have found that after developing on a “reasonably” high end Gaming PC, when we go on to re-test on a slower machine, there are differences, that need to be addressed, so our product will run correctly with other running apps, on both High end and low end PCs.,

The WT GNS530 is an good example, where we have found we need to put extra delays into our code, to wait for other Dev’s code to complete a task, and make those delay long enough to cater for a min spec PC system

1 Like

I am unable to reproduce any of these autopilot issues (even on my super min spec laptop).

However, we have had some reports of these exact symptoms with the TDS GTN installed (even if you pulled it from community, as it runs an exe that intercepts AP commands that the WT GNS is also trying to). There is an update available for the TDS that cures these issues.

As far as the instrument size goes, I am unsure why the WT GNS displays correctly and the AS430/530 does not, but it appears your size_mm and pixel size definitions are not matching in the panel.cfg, potentially.


Hello @LyonHaart001

I made a quick test flight with your TB21 aircraft and WT430/530 package installed and didn’t notice any issue either.

And as mentioned by Matt, when the WT package is uninstalled, the display issue with AS430/530 comes from the mismatch between your gauge resolution and what is passed to size_mm.
As indicated in the doc, the gauge will take a fraction of the screen in this case.


Thanks guys for testing this.

So I just took up the Cessna 172, starting ‘in-flight’. The Cessna 172 Classic AP performed proper. I tried turning it off and on, changing HDG, turning ALT off and on to see if I could replicate what others were having, and it behaved as it should.

I then loaded up the Trinidad, via using Aircraft Selection Tool in Dev Mode options and loaded directly into the Trinidad TB21, and she would not hold ALT setting. Rebooting the AP (off and on) 2+ times didnt work. She also wasnt holding HDG. 2 Weeks ago, she was fine, so it could be an issue from changing from one plane to another, but they both use the same GNS’s and same KAP AP.

Also, the clustering of the screen has never occurred till now and other developers have reported this also.

I hoped this was fixed, flying the 172 just now and the AP was fine. What a strange issue. I wonder what is going on…

Can you check if you have the same problem when going back to the world map instead of using the aircraft selector to switch between airplanes?


Sylvain, that worked! The 172 ‘and’ the Trinidad both worked well.

Switching from plane to plane in the Aircraft Selection Tool must break something in the AP linking with the new code, and going back to main screen bypasses this issue.

I’ll let me customers know.

Many thanks.

Lionheart Creations

Some customers said that they could fix it by rebooting the flight. They must have gone back to the main screen and restarted from there to restore the AP.

Can confirm this, especially since the introduction of the WT GNS Gps systems.

As a general rule, it is currently best to assume that any quick reload, or change of aircraft (or any similar operation in the Dev panel), “CAN” cause unpredictable behavior, and the only way to guarantee (if any Guarantees are possible), is to RELOAD from the nondev console menu, or go back to the main menu - world map, and continue from there.

Even changing instrument selection within your plane (if it supports it), can mess up those swapped in instruments, especially the GPS systems.

1 Like

I just tested this on the Trinidad today (FEB 16th) after the newest Beta of the SU15 came out, and my Autopilot will not link NAV, and VOR instruments will not lock on VOR targets.

I then tested the Asobo Cessna 172 Classic, which has identical Autopilot and GNS530 systems and it too would not link.

To test this, go into a flight, set GNS530 to nearest VOR target frequency and go to CDI mode. Your VOR1 instrument should link in, and Autopilot should link to the VOR1 signal as well in AP NAV mode. But no. Oddly, VOR2 says ‘go right’, but as you rotate the knob, it stays right. But with VOR1, which is controlled by GNS530, ‘nothing’… (Its dead Jim… Its dead).

At first, this was semi working. But now it seems the KAP140, VOR instruments, and AP linking are broken in this new version of Sim Update.

Anyone else care to test this and see what they find?

My testing area was San Diego, trying to link to targets from KSAN on Northward.

I did try to reload the flight once, and it did nothing.

Lionheart Creations