Autopilot NAV Lock not Engaging

The autopilot nav lock on my aircraft has worked for some time now, but within
the last several weeks, it will no longer engage. Playing around with
different options, I finally got it to work again, but my solution is far from
ideal. In order to get the nav lock to work, I displayed Simvar Watcher to
verify that the variable “GPS DRIVES NAV1” is set to zero and then I
temporarily repurposed another switch to first set that variable to 1. After
verifying that the variable is 1, I hit the switch again to set it back to
zero. After doing this, the nav lock works as expected for the remainder of
the flight. I am not sure what is causing this. I looked through my
systems.cfg and could not find any setting under autopilot that I thought
would effect this nor do I have any other code interfering with this. Was
there a recent change in how the nav lock works that I missed? I’m at a loss,
anyone have any ideas? Thanks

By default the GPS Drives nav1 should be zero. If you do not use the fix
switch and click the nav lock does GPS Drives nav1 change to a 1 ? I have to
say there is nothing wrong with this event and will be hard to help solve this
and will need more info.

Hello @MtnFly I tried to reproduced your issue but for me this variable work
as intended, maybe the issue come from your package, you can send it to us and
I will have a look at it to try to see where the problem may come from (see
[3) provide private
bug-or-crash.html)). Best regards, Yohan

Yohan, Thank you for the reply. I did a little more digging and I did find the
issue, sort of. In my panel.cfg, I have the following text block: [VCockpit01]
size_mm = 320,234 pixel_size = 320,234 texture = $AS530_Screen htmlgauge00
=NavSystems/GPS/AS530/AS530.html,0,0,320,234 When I have this block of code in
panel.cfg, the NAV hold will not engage, but if I remove it, the NAV hold
works again. My aircraft has analog instruments, but I inserted this this code
for 2 reasons.

  1. The user will have the option to switch out a weather radar for the GNS-530, hence that code.
  2. My aircraft has a speed hold option in the autopilot and without the AS530 code, the FLC hold will not work as the aircraft porpoises uncontrollably. But with that code there, FLC works like a charm. Note, I really need both airspeed and MACH holds, but they will not turn on, only FLC seems to work. (This is my next issue I need to solve). But none the less, the AS530 code is the only way I can get the FLC to work.

The NAV hold has been working since day one and stopped working after AAU1 was
released, after which I began to see the issue with the NAV hold. I am not
sure if MS/Asobo will call this a bug or just take the stance of this not
being supported (which I would understand). If I am not able to use the AS530
code, I do have the option of creating a second aircraft to select, which
solves one part of this. The other issue is that I need the airspeed/MACH/FLC
holds to function properly, but I am sure there is a more elegant solution to
this then adding the AS530 code (if anyone knows of one, please share).
Anyway, I do have an aircraft version that displays the NAV hold issue and in
the event that you would like to see what is happening, I will send you a
private message with how to grab it. Thank you

FYI, I am not sure why some of my message above was bolded. Ignore that.

Hello @MtnFly We have tested your package on SU12, AAU1 and SU11 and the Nav
Lock did engage as expected. Maybe we are not understanding your issue? For
you, “AUTOPILOT NAV1 LOCK” simvar is always set to 0? Best regards, Yohan

Hello Yohan, I created a short video that I uploaded to Youtube. I will send
the link to you in a private chat. In the video, I show that the AS530 is not
in the panel.cfg and demonstrated that the NAV lock worked. I placed SimVar
Watcher at the bottom of the screen for you to verify that the NAV lock did
engage. The second flight, I rebooted MSFS and showed you that the AS530 was
included this time, however, I clicked on the NAV button multiple times, and
it did not engage. Although this is an issue, my ultimate goal is to get the
airspeed/MACH holds working which do not work (the aircraft porpoises
uncontrollably up and down), but I was able to get the FLC hold to work as
long as the AS530 is included (without the AS530, it porpoised again). The FLC
working was a small win in my testing to ultimately get the airspeed hold
working and I am going to open another post for that, but none the less, the
NAV lock was an unfortunate casualty of that testing that only cropped up
recently around the time of AAU1 release. Thank you.

Hello @MtnFly I did try to reproduce what you show us in the video with your
package but not only my nav lock worked but the “GPS DRIVES NAV1” simvar
worked too and it worked in a post AAU1 dev build as well as in a SU11 build.
Maybe this issue is coming from another of your package that conflicts with
this aircraft. I suggest you check that and maybe retest this issue when the
SU12 flighting begin. Best Regards, Yohan