Cannot Debug WASM Module ( not quite a repeat)

I’m experiencing almost the same problem as shown here: Imposible to get WASM debugging - Questions & Community Discussions / WASM - MSFS DevSupport (

However, I’ve tried every option suggested so far - none of which have resolved the issue - so am starting a new topic.

My WASM is not for gauges - it’s a straightforward SimConnect WASM like the SDK standalone WASM example.

It compiles OK, and MSFS developer mode seems to accept it as well. There are no error messages associated with this project.

MSFS is running with -AllowDebug extension.

I’m using the Debugger extension. When I set breakpoints, and Attach to Process, nothing happens - no breakpoints are met.

The Output Window is blank, but the Immediate Window floods with the following message: ‘Exception thrown at 0x00007FF64E706B20 in FlightSimulator.exe: 0x80000004: Single step.’

This is similar to what SimbolFSReborn reported, but his screen shots show a slightly different address (0x00007FF644326180), but in the Output Window.

I have checked every setting in the project, and find nothing unusual.

So I tried compiling the ‘standalonemodule’ example (‘MSFS SDK\Samples\DevmodeProjects\Misc\StandaloneModule\Sources\Code’) in the SDK - and it gives me exactly the same exception messages as soon as I try to attach to FlightSimulator.exe.

I’m at a complete loss. Can anyone shed some light on this?


The Signe step exception is a exception raised by the CPU to help debugger runs “line by lines”.

It is not necessary to catch it on your side because your debugger already does it.
To do so, in the “Exception Settings” tab on Visual Studio Debugger, restore the exception triggers to the default list. If it is not sufficient, you can manually uncheck this exception to ignore it when it is raised (you can also use the ignore button next time the popup shows off).

Best Regards
Maxime / Asobo

Thank you Maxime. Your suggestions have helped me make the problem go away, but I’m not sure it’s actually solved it completely. I also don’t understand why no-one else has encountered a similar issue.

What I did was to switch off all Exception Messages in the Output Window:

While those specific Single Step exceptions no longer appear, it seems to me (unless I’m mistaken) I won’t see any other exceptions now in the Output Window, which seems a bit of an overkill.

Nevertheless, I am now able to set breakpoints, and they do get hit, so I’ll mark this one as ‘Solved’. Thanks for your guidance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.