Clutch_maximum_torque_down misnamed and not working

Version: *SU14±1.37.12.0

Frequency: Consistently

Severity: High

Context: *Developing/Debuging helo turbine engine to rotor connection.

Bug description:
[HELICOPER]
clutch_maximum_torque_up This is the clutch simulation maximum clutch torque when the engine [RPM] Default value is 1000. Float No
clutch_maximum_torque_down This is the clutch simulation maximum clutch torque when the engine [RPM] Default value is 1000. Float No

definitions are the same, when they should be different.

clutch_maximum_torque_down defines transfering torque from the engine to the rotor. This is working correctly. Can be verified by reducing value to ‘0’, and no torque is transfered from the engine to the rotor.

clutch_maximum_torque_up this parameter should be to adjust the torque that is transfered from the rotor to the engine. In a real heli, this is called the ‘sprag clutch’ or ‘freewheeling unit’. It is critical and is tested before takeoff to check functionality. In the critical case of an engine or gearbox siezure, the rotor is allowed to keep spinning, without drag (the adustment value on this parameter) so the when the engine stops, the rotor doesn’t stop too.

Simply: the engine should be able to drive the rotor, but the engine should not be able to drive the engine.

Repro steps: Using ‘debug engines’ dev tool:
Reducing the ‘master throttle’ from 100% to 0%
‘Engine shaft torque in’ reduces from 85lbs/ft(arbitrary idle number) to +9.2lbs/ft not the ‘0’ torque required to release the rotor from the engine/gearbox.
clutch_maximum_torque_down changing this value has no effect.

Another way to test is:
From idle, roll up the throttle. Eng and rotor needles will rise together.
From full throttle, roll off the throttle to idle, the eng needle should reduce to idle ahead of (before) the rpm needle.This is called a ‘needle split’.

Attachments:

Private attachments: Send a PM to @PrivateContent with the link to this topic and the link to download your content