CTD/Freezes in Bush Trip - Not seen anything like this before

I have created more than three dozen bush trips using BuffyGC’s excellent
BushTripInjector (BTI) software. I am currently testing my latest trip from
Alexandria to Abu Simbel in Egypt broadly following the River Nile. I have
chosen the Cabri G2 for this trip as I intended to place purpose built
helipads, made with BTI at selected points where there was no convenient
airport or heliport. As a result, the trip contains a mix of msfs airports,
the Giza helipad and about half a dozen helipads made with BTI. This is the
eighth trip I have made using helipads so I am reasonably experienced in
placing them. The trip starts with a couple of legs using the BTI helipads.
Leg one worked fine as leg two seemed to. When I later loaded up the third
leg, the progress bar on the bush trip loading screen froze at about 40%
complete. I needed to use task manager to quit the sim. I emptied my community
folder of everything except the trip and tried again with the same result. In
the end I changed the third landing point from a BTI helipad to a nearby msfs
airport and was able to complete the leg. Starting the next leg was fine
except when I landed at the fourth helipad the game did a ctd. Moving this
waypoint to a different location with both a BTI helipad and msfs airport has
given the same result - CTD. The sim will allow you to start a trip from the
fourth location but results in the 40% freeze again. I sent a copy of my trip
to BuffyGC who tested it and confirmed my most recent results in terms of
CTDs. I have not had these sorts of problems before in any of the bush trips I
have made and would appreciate any advice on what to try next. Best, Prof

Hello @ProfSC , To investigate this we will need your package and the
generated dump file. See the article “[How to report a bug or
bug-or-crash.html)” Regards, Boris

Update: I replaced the msfs Giza Helipad with one I made in BTI and positioned
nearby. The trip now works as expected with no freezes or CTDs in the entire
trip. I am 99.9% sure the problem is with the Giza Helipad in this instance.