CTDs The instruction at 0x*referenced memory at 0x*. The memory could not be written

I VERRY often get CTDs with the following error message “the instruction at
referenced memory at 0x00****** referenced memory at 0x00*******” Link to
several dump files:

Hello @Integralo I encourage you to follow the guidelines provided here to
report a bug or crash: [http://devsupport.flightsimulator.com/t/how-to-report-a-bug-or-
crash/77) Providing an error prompt and mini dumps without context is unlikely
to be enough information for us to diagnose the problem most of the time. In
this particular case, I was able to see the crash occurs in the DirectX 11
dll, so it’s very likely those crashes are not DevMode related but are
identical to the DX11 crashes encountered by many players at the moment.
Solving this crash is the main focus of the engine team at the moment. You can
provide us with a full dump file if you want me to confirm this diagnostic.
You can also try to switch to DirectX 12. Some users reported having less
stability issues when doing so. Regards, Sylvain

I have a partial solution for you, having this issue as well. It seems to
happen only when working with aprons and runways. I can place buildings, edit
taxiways, and draw lines and nothing will happen. I have found that by locking
the exclusion and the mesh polygons, lengthen the time between the crashes.
Unfortunately, it still crashes, but not as often then.

Me and another friend who develops airports are also having this problem and
it only happens when working with Aprons (at least for us). I spend all day
making lines, placing objects, creating polygons normally, but if I start
using Aprons the simulator crashes and this message appears. A detail worth
mentioning is that I wasn’t having this problem on Windows 10, it started
happening after I started using Windows 11.

I have solved my problem by looking up the airport XML file and then edited it
with a TXT editor. I hope you can read XML. It is not too difficult. Many of
my airports are old FSX airports designed with ADE (Airport Design Editor from
Scruffy Duck). He brough out a version of ADE for MSFS with which you can
convert your airports to MSFS format, but it looks like this method is not
fool proof. Most of the time the conversion works, but not all the time! In my
case, I found and entry for an ILS under my runway configuration that was not
supposed to be there. I have no idea where it came from as the airport, I was
editing does not have an ILS and it was not in the original FSX file. At least
so I think! I removed the ILS entries, saved the file, and then opened it in
MSFS DevMode. No crash at all! I did not check, but I suppose that the ILS Lat
and Long was for another airport and that is why my airport kept crashing. My
suggestion is that you do the same and check your airport XML file for
anything that should not be there. It will be in the <Airport section of the
file; not the objects that you have placed.

I also notice the issue is very repeatable working with Aprons - just
reproduced the exact same memory reference three times in succession working
with different aprons . Modelling , object placement , lines seem to work
quite well. Mine are all read errors not write errors as per this title. In
contrast to other I’m still on Windows 10.

@Integralo @FSoares @CIAE985 @FlyingRaccoon I HAVE SOLVED THIS ISSUE! After it
annoyed the hell out of me for weeks! Ok, first my setup: Windows 11, 32Gb
RAM, nVidia GTX 1660 Graphics Card (6Gb RAM). The issue that cuases this crash
is with the latest nVidia Driver. I uninstalled my nVidia Drivers (latest
version), restarting my system several times in the process and then I let
Windows download and install the latest stable version driver from Windows
Update. I am now running V456.71 of the nVidia Drivers, which is older, but it
works and MSFS no longer crashes. I have been testing this for the past three
hours designing aprons, drawing lines and roads and no more crashing! Give it
a bash!

@Space.Baron have just returned from leave and read you post on nVidia V456.71
to address the apron issue. Given its now been 3 weeks (and this driver is
from October 2020) , could I please check the fix persisted for you ?

I am now busy with my second airport after the fix post and it still works. No
more crashes at all! It is a real pleasure working like this now! No more
sitting on the edge of my seat waiting for the next crash and restart and as
you know, restating MSFS is not a quick process, even if it is installed on an
SSD! I don’t know what the older driver does that the newer one does not, but
it works! I have heard from other sources that the latest nVidia drivers are
not always stable so maybe that is it. The driver version I have is 456.71
released 2022/07/13. This is the one that Windows update loaded for me for my
nVidia GTX 1660 (6gb) graphics card under Windows 11. I hope all this helps!

Oh - I just realised we are talking different GPUs. I have an RTX3900 and
456.71 for that is from October 2020…LOL…Glad it worked for you , guess I
could try some others drivers or just hope for a fix next SIM update as the
problem is very general outside DEV mode.

No worries, just uninstall the driver you have loaded, restart your PC and
then let Windows load the driver via Windows Update like I did. There should
be one there for the AMD as well just like there is one for the nVidia. It
will be an older driver, but it should work just like it did for me. In fact,
I cannot see why this will not work. Give it a go and see what happens! You
cannot do harm at all.