CUBICSPLINE interpolation - for animations are not working in Simulator

I have been trying to overcome long export times in the Blender exporter with
Blender 3.3.7. I have found that Khronos is exporting ALL NLA animations, even
if you mute them (uncheck) in the NLS panel. These animations are also
sampled. This will result in export times increasing by 10 fold. So 10 seconds
before now export in 100 seconds. In order to help with this issue. Khronos
have added an option to not sample animations. There is a animation setting
“Always Sample Animations” If this setting is unchecked the export time
reduces back to a resonable time for a development work flow. Unchecking
“Always Sample Animations” works fine for most animations except ones created
with a follow path. The follow path is baked along with a rotation NLA and
combined into one baked NLA animation. However exporting with “Always Sample
Animations” unchecked results in a difference in the gltf of having the
interpolation being CUBICSPLINE instead of LINEAR. I assume Khronos will not
change the way these exports are done. Could ASOBO please handle CUBICSPLINE

Ok answering my own question. Seems nurbs curves for follow path animation are
set to bezier curve, So the resulting export is CUBICSPLINES. Suggestion from
Khronos is to redo the actions by “Select all your keyframes on your actions
→ T → Linear (in Graph Editor)”