Customers experience default airport buildings showing on top of custom airport that worked fine previously

Hi, I have 2 customers who purchased my CYOO in MSFS marketplace that have a
similar problem: they see default airport buildings together with my custom
buildings throughout the airport. They occupy the same place and create a huge
mess. I haven’t made updates to this airport in months, and it worked fine all
that time. I suspect it’s one of the recent MSFS updates that did it. I use
normal exclusion polygons to exclude buildings and I’ve never had a problem
like that. I have a similar problem with the tower, but that one is due to the
separate tower exclusion box that was ignored previously but then started to
be followed. So I know about duplicating tower problem. But this is different

  • as far as I can tell it affects all buildings.

Hello @RomanDesign I checked your package. You
seem to have placed polygons with buildings exclusion option specifically
around certain parts of your airport; I assume where you were able to see
buildings when you edited your project… This means newly added buildings
(when the automated building detection process is run on our side, or we
refresh the OSM source, etc…) will not be excluded. That’s probably what
happened when World Update 11 covering Canada was released, adding a few
buildings. What you want to do instead is to have your building exclusion
polygon cover the whole area where you are sure you don’t want any conflict.
Regards, Sylvain

I don’t think that’s the case - all those buildings were already present where
I created custom buildings. Exclusion polygons were placed individually around
every one of those buildings, and they worked. Those are not areas that were
empty and thus uncovered with exclusion polygons. I did the same in all my
airports. Same user also has my CYKZ (Toronto) and this issue is not present
there. Maybe I didn’t understand your explanation correctly? But how is
placing one large exclusion polygon would be different than smaller exclusion
polygons if they cover the buildings anyway? Those buildings may have been
regenerated, but they are at the same places where my exclusion polygons are.
They should still be working correctly, but they aren’t. Why?

Because there are Blackshark AI buildings that may get placed “randomly” I
think is what he meant. Be that as it may, why do you prefer multiple
disconnected exclusion areas over a larger building exclusion area, are you
trying to keep some vegetation? (I’m not judging here, just want to understand
your process and concerns) To that end, you could have multiple exclusion
polygons on top of each other for different things. Would that help? Is it
possible your exclusion polygon is different, or the buildings are different
than what you were thinking you were excluding? There’s buildings and there’s
TIN, need to exclude both. But excluding TIN will exclude TIN vegetation and

I use one polygon per building or a group of buildings (a block), to keep AI
vegetation around the airport in general, and occasionally some small AI
building that looks close enough, or is unimportant. Polygons cover the
building plus some area around it (usually up to the roads around it). The
ones on the screenshot are exactly at the same place as mine, the walls are
within inches of each other, so they are definitely covered by the exclusion
polygons. And this has worked for months, with only changes by MSFS itself. So
it’s not something I did wrong, I think, because it did work before, and the
same approach still works at CYKZ.

So, as I noted, I tend to create multiple exclusion boxes and vary the option
between each one, rather then suppress everything with one box and turning on
all the options. In the past I’ve found I have to create larger exclusion
boxes to exclude some things, especially parking lots of cars. Those can be
pesky. What you may be having an issue is that some models include multiple
buildings, so an exclusion box over just one of the buildings would not
suppress those buildings. The exclusion rectangle I think has to include at
least the origin of the SimObject, and may need to cover the whole thing. This
shouldn’t be an issue with TIN, as the exclusion boxes will typically do ok at
suppressing what’s inside them, though, again, if the TIN sits a teeny bit
out, that TIN won’t suppress. I tend to suppress all TIN vegetation anyway
since it’s so ugly. And, to that matter, I also tend to create my own
vegetation, too, depending on where it is.

Those AI buildings are an exact match in size with my custom buildings, within
a few cm. And my exclusion polygons are always larger than those excluded
buildings. And again, this exact airport is selling for many months and it has
always been OK. Suddenly with no changes, it’s like this, at least for some
users (but more than one for sure).

Hello @RomanDesign I can’t see any building
exclusion shape where you have those conflicts. Here are pictures of the
buildings you shown:

as opposed to some other
buildings where the noBuilding is correctly set:
Regards, Sylvain

That is not possible… Do you think it could have disappeared from the
marketplace package somehow? Even those 2 customers told me it was working
fine before, and just started doing this recently, and I’m 100% sure it wasn’t
released with this building showing like that. That leaves only two
possibilities: either exclusion polys disappeared from the package somehow (or
are corrupted or ignored by the parser etc.) or those buildings have not
existed in the first place, so they are not excluded because there were
nothing to exclude, but were added later by the MSFS AI. That’s actually
possible, I think. I wouln’d have excluded something that did not exist, and
if this was added later, that’s how it could have happened…

That was my first assumption. With World Update 11, data has been refreshed,
leading to some building being automatically added. That’s why I said you
don’t want to use exclusion polygons on very specific buildings but rather on
an area where you know you don’t want any generic buildings to show up.

1 Like