DevMode Bugs SU7

After opening a scenery project in DevMode, Changing the weather can cause a
CTD. Also, Slewing is often disabled while working on a project. And. of
course, Notofications are reset to Easy when working a project.

I have Steam version of sim and installed SU7. After opening a scenery project
in DevMode, will simulator crash on screen.

I also have huge performance drop to single digits (down to 5 fps) when moving
taxiway points across the screen. As soon as I let the point go, performance
becomes normal 50 fps. Something is totally broken.

I know I have posted elsewhere but this is ridiculous now. No editing

I am having the same issues (STEAM). I get a CTD under the following

1. Click FLY and and use the INS key to view outside. I can go up/down (W/F)
but as soon as I use the numeric 4 or 5 I get a CTD. My GPU goes for 90-100 to
0% and then CTD

2. Click FLY and use DEV mode. Load my airport etc. Using the W/F/A/S/D keys
same thing after a few seconds - especially near scenery or models that are
complex. If I touch the numeric keyboard arrows (rather than the W/A/S/D) the
CTD happens instantly.

This has not been an issue before SU7. I might also add that after 2 CTDs I
seem to be able to last a little longer before the CTD.

100% repeatable and rather annoying…

For what it’s worth…Exception code: 0xc0000005 Fault offset:

The project (in fact any project) is clean, no errors and no misplaced points
etc. This is something that has crept in since SU7 was released

I wonder, when the MSFS process crashes (to desktop), is any information
(stack trace etc) sent to the developers? If not, how can the developers even
be aware of such crashes and fix them? If it is seen as too burdensome to
receive automatic crash reports from end-users, could such crash reports at
least be sent when the process crashes in developer mode?

Hello @Ironpot Can you confirm you’re working with
a retail SU7 version and not with a SU7 update testing version? This crash
looks a lot like one we have fixed in that beta version. Regards, Sylvain

Hy Sylvain, Downloaded and applied through the normal MSFS update when
loading. Have not sourced from anywhere else. Any other way of checking for

What is you game version number?

Hi Sylvain, version numbers as follows: MSFS and SDK 0.16.0

Several of our development team have severe crashing to desktop … its making
development very painful. At this stage its unworkable and we are thinking of
taking time off until it’s going to be fixed. Over the past week we have lost
so much work to crashing. We have also tried the older Nvidia drivers … same
issues. Were on the SU7 retail version … See you in the new year on
hopefully a more stable platform.

I confirm the problem. The sim is very hard to work with at the moment (SU7).
@HybridNZ I found that lowering all the graphics
settings helped a bit.

So the problems are getting worse. It’s started with CTD when using dev mode,
some days its fine then I will have a night of it being terrible … crashing
about 20 times in the night. I tried uninstalling and installing the preview
version of SU7. Its crashed about 4 times so far on decompressing the
packages. I suspect it’s because it’s using the GPU to assist in the
decompression process of the packages. Interestingly twice but not every time
… the background desktop image dropped colors for a few seconds then came
back. This is starting to really feel like a Nvdia firmware (not just driver)
and the way Microsoft Flight Simulator is using the APIs ? I’m pretty sure its
not localised hardware issue and is only tied to MSFS. Haven’t had any
problems in other games or 3d software. There is something pretty serious
going on between MSFS and what is doing with the APIs and the new
Nvidiafirmware/software. This problem only started after the use of the Nvidia
driver 497.09 … I have removed that driver and rolled back to 496.76 … but I
think its probably already installed the firmware. Attached is a screenshot of
it hanging for a very long time on the first decompression after its
downloaded all the of packages for fs-base-cgl-0.1.75.fspackage The reason the
download is only 70GB and not 130 is because of the restarts after crashing.

Hardware: 9900k-i9 ASUS Prime
z390 64GB mem Asus Strix RTX 2080 running at 4k (2 x 4 Samsung 28inch flat
panels)Have also replaced the power supply with a Cool Master 1050watt Gold
modular unit. No change there. I’m happy to work with you guys, just reach out
here or Ill pick up an email on our monitored public inbox.

Hi. Try rolling back to this version of NVIDIA 472.12-desktop-
win10-win11-64bit-international-whql by doing a clean install

Nope, full uninstall of anything Nvida and fresh install of 472.12 This is
after downloading about 60GB again of the fs-base-cgl (66 or so packages) …
as soon as it goes to decompress using the GPU… this happens. Things are
pretty broken. It constantly happens … although a total pain in the ass to
download it all each test run … it’s reproducible. I have video of after the
crash and my system back online I can run up other games fine… no problems
what so ever. So its not a hardware issue my end.

Hello. Most of these crashes were fixed on our side. Those fixes will be
included in a patch for SimUpdate 7 but there’s no ETA yet. In the meantime,
you can check if you can still have access to the public test program: [Pre-
release Testing - SU7 Update Public Flight - Community / News and
Announcements - Microsoft Flight Simulator
public-flight/479364) [Pre-release Testing - SU7 Update Public Flight - now
also for Steam Users - Community / News and Announcements - Microsoft Flight
Simulator Forums](
su7-update-public-flight-now-also-for-steam-users/480068) Regards, Sylvain

Thanks for the info Sylvain, We will tools down and go enjoy Christmas. Merry
Christmas to you and the team. Thanks for all your support and being so
interactive with the dev community, you and the team have been a massive help
this year. Looking forward to it all next year. Yes thanks I still have access
to the test programme as a Microsoft partner. All of this was done on the
preview build we currently have access too. NB: For anyone else wondering, I
tried the latest 497.29 drivers just release from Nvidia, same issue …
crashed during downloads.

Thanks for the info Sylvain and for support. I wish you Merry Christmas to you
and the team. Looking forward to next year. Cheers! :slight_smile:

Right last one from me, I’ve managed to install it by going back to retail
(Non-preview build) and using 497.29 that were released yesterday. The
installed completed with no issues from scratch. So the black screens and blue
screens / sudden reboots have gone - that was obviously the 497.09 driver
doing that. All the other CDTs and performance issues are now awaiting a
stable build from asobo. I am now able to at least finish off some final
development work before xmas shutdown which is all I needed.

@FlyingRaccoon Hi Sylvain, I changed to the pre-release version (Steam) as you
suggested and indeed the majority of the issues I was having have been fixed.
I had one CTD where I was back fiddling with materials in an Apron on YMML
which you once looked at. However I didn’t get the dump from the crash and it
hasn’t resurfaced. So again thanks for the efforts in looking at our
complaints etc and getting us back working. Enjoy the Christmas and New Year