Elevation offsets sometimes ignored on loading

This has been an ongoing issue for a while. At least since late last year, but
likely earlier. It doesn’t seem to matter if you use the standard AGL offset
value or if you have low resolution elevations checked off. If you place a
scenery or simobject and set an elevation offset value, sometimes on load-in
the sim will ignore the value. Sometimes models will later pop to their
correct altitude, but also, sometimes you just have to restart the flight or
go back to the main menu and load in again for it to display correctly. There
does not seem to be any real pattern to it. Luckily most models are just
placed AGL, but often times I may need to sink something into the ground or
raise it a bit, so not having these models placed where they need to be can
look a bit odd. Especially in the odd cases where a large offset is needed and
a simple offset in the model itself wont do (If a model is being placed more
than once). An example would be this race course that I just finished, where
the model origin is in the center of the object:

These should normally be
floating about a meter or so off the ground with an offset, but the value was
sometimes ignored (They have now been revised to have an offset in the model
itself). In all cases that I can currently think of, some form of terraforming
was involved, whether it was added by myself or placed over a default area (In
this case), so possibly it could have something to do with that or just
loading order?

I solved this by using “USE LOW RESOLUTION ALTITUDE” under object properties ,
because you use AGL depemding on your distance to objects, MESH LOD can vary
and then ALT is recalculated. here you can read about this
… Cheers

If you want your objects to stick at a specific altitude, Set in the xml
altitudeIsAgl=false and in the alt= the right altitude (you see it from the
gizmo) So the objects will ignore any terrain LODs

Hmm. I still have this happen with Use Low Resolution Altitude. In fact, those
gates you see are set to low res altitude in the photo.

Is that the same as use low resolution terrain? I’ve never paid attention to
what that option sets in the XML.

Nope, it make the sim using absolute altitude (AGL is by definition relative)
I used it a lot for my pylons (because I need to calculate at design time the
angle and position of each cable)

That makes sense… I assume it will revert back to True when updated in the
scenery editor, though? Will have to give it a try.

@mamudesign I finally got an opportunity to circle back to this issue (on
another scenery) and try your recommendation. I made sure that Snap to ground,
Snap to Normal, and Low Res Altitude were all unchecked, grabbed the altitude
from the Gizmo tool, plugged it into the XML and set altitudeisagl to false.
Unfortunately I’m still seeing an incorrect elevation when I spawn in, which
only corrects when I begin to move toward the object. Just curious if there is
any combination of things I could have missed? Though, I don’t think so… I
did verify that the changes all stuck.

I confirm the issue. All SimObjects used to behave like this, except for
“Landscape” category - they remained fixed at the right altitude. Recent
updates (SU11?) have broken this behavior and SimObjects sometimes spawn at
ground level. In addition, sometimes they pop back to the correct elevation
when switching to outside view for a moment (feels like it’s triggered by LOD
switching). For example, here’s a standard SimObject with nothing complex,
just a few LODs and model behaviors that simulate a docking device - but
sometimes it spawns on ground and remains there:

I have tried everything
suggested in this topic so far, but none of that helps.

Just some additional information based on my previous reply to Mamu above. At
that time, my model did not have any custom LODs (It does now - same result).
Unless the sim itself does some form of auto decimation. The SimObject is also
sorted under Misc.