Engines Will Try To Start but Not Ignite

We are managing startup ourselves but using the built-in starters, of course. We monitor the starter and fuel valve values and toggle them ourselves in accordance with the systems to start it and it works relatively well. That said, sometimes, there are scenarios the engines will motor up to ~28% N2 but will never ignite, despite the fuel valve being open.

We have ensured (via the simvar watcher or similar) that:

  • Starters are engaged
  • Master ignition / starters are engaged
  • Mixture is set to a non-0 value (though, it is a jet and our code forces mixture to 100)
  • The fuel valve is open
  • There is non-zero fuel flow

Despite the above, the EGT never rises and the engine never officially “starts”. Interestingly enough, in these scenarios, CTRL+E changes something and the engines suddenly start, and can be restarted via our custom systems afterward. There is a variable or mode that CTRL+E must change that we’re not aware of. Any guidance would be appreciated.

Thanks in advance.

Hi there,
We’ve found several interesting “quirks” about the engines/starters when we are doing our engines so hopefully this help. So far, we’ve been able to start our engines reliably every time.

  • Not sure what SimVars are set when you say “Master ignition / starters are engaged”. We set TURB ENG IGNITION SWITCH EX1 to “2” during the start phase, setting it to “1” or TURB ENG IGNITION SWITCH to “1” only work sometimes.
  • If you read/write the engine parameters, like the N1 or CN1, they could interfere with the combustion state if they are set “incorrectly” (depending on what you put in your engines.cfg). Try nulling out that part of the code to see if it improves.
1 Like

THANK YOU! Forcing that variable to 2 immediately solved the hung start. That variable is actually listed as read-only in the documentation, so we never would have tried this.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.