Flight surfaces with wingflex

Hi! I have managed to implement wingflex to one of my projects, and the wings
bend just as they should, which is great! What is not so great however is that
with the current way I have animated the flight surfaces located on the wings,
every surface moves whenever I move just one of them, say for example when I
move the ailerons the flaps moves as well, not exactly what it should do… I
have tried many things out, but none have seemed to work for me. I have taken
looks at other planes with wingflex, and I have currently been parenting the
flight surface meshes to bones that are connected to the right wingflex bone,
then animated them as they should be, but it seems like when I get multiple
nla tracks under the same armature object, every animation effects each other.
If someone knows a solution I would be happy to hear!

There should be no relations between flaps, ailerons and wingflex. This sounds
like an issue from your model. Are you using Blender or 3DS max? I can’t help
you for Blender but can for 3DS max. I would start to look at your bones and
animations and do some testing to rule out the issue.

Hi, this is unfortunatnely a limitation if you are using the blender exporter.
Blender seems not to support the animation groups like 3DSmax does. I
reuqested a fix on the Github and hopefully Asobo is going to solve the issue
before we get too old. This is the most important issue to get solved with the
blender exporter currently. here the issue explained:

This sounds exactly like the issue I have been experiencing! Weird that I
didn’t hear about this issue before. What about the other exporters? Have you
tried those, if so which? Thank you anyways for letting me know, now I won’t
be spending another whole more week trying to make it work…

I tried everything, also various methods and possible workaround, that just
sucks, NLA will end up mixing if you have more than one on the same object,
even if you have 1 armature with multiple non related bones, all NLA will
belong to 1 armature, and that mixes up.

I have the same problem. I am using the Asobo Blender exporter and Blender
3.1.2. The wing flex is good and my first animated flight surface works as it
should. The problem begins when a second surface is added and then they all
start moving together. As mentioned above, the NLA tracks appear to be mixing.
There is someone on fsdeveloper who apparently had this working correctly but
that was some time ago and he would have been using the old unofficial

OK, so I got this to work. You need to uncheck the channel muting boxes
opposite the NLA track names in the NLA editor. When you do that the
animations won’t play in Blender, but will work correctly in the sim. Still
working this out. So far I can only get it to work with stock animations – I
have complex spoiler animations controlled with my own xml animations and am
still having trouble with those.

Just checked and that actually works! Thank you so much Michael! I appreciate
it a lot, having spent countless of hours on trying to get it to work, I got
very upset when it didn’t. This really made my day!