Framerate issue with SU15 beta

Hi MSFS/Asobo team, we just tried the SU15 beta (1.37.12.0) but we get a serious framerate issue with our in development plane. With SU14, we get 86fps, but we only have 71fps with SU15. We developing the plane with WASM. We also tested pmdg and fenix, these 2 planes also lost fps. At SU14 Fenix = 86fps, pmdg = 87fps, at SU15 Fenix = 76fps, pmdg = 79fps. I’m not sure if only my pc have this issue, any good ideas? I thought to post this before SU15 gets released in the case that this is caused by a bug, or was there any changes that we need to know about so that we can make the required changes?

1 Like

Hi,

Is MS/Asobo going to do anything about this heavy frame rate lose?
I just tried 1.37.17.0 and it is still the same.

Hi,

Some big changes has been made on Wasm for SU15 (stack overflow detection, decommit memory) but we are not aware that those changes could reduce Framerate that much.

Can you provide us with some data about Wasm execution time between SU14 and SU15 (in the same condition : same plane, same version…) using the Wasm Debug Window :

In SU15 build, can you also provide us with the Decommit Duration data that you can find at the bottom of this window :

Thanks for pointing out that issue

Best Regards
Maxime / Asobo

I had a massive hit on frame rates in SU15 also. I updated my nVidia driver and it went away completely. Check your drivers. It ‘might’ be that.

Hi Maxime, the build 1.37.18.0 released today fixed the problem. Thanks!

I can also confirm that the build 1.37.18.0 released today fixed the issue for me, even improved performance a little bit with about extra 2-5fps.
Thank you!

@CheerierAmoeba1, @JannieR2007,

May I ask which platform you are running your tests on? Store version, Steam version or Xbox?

Best regards,

Eric / Asobo

Hi Eric,

We are both on the MS Store version.