How to "un-maximise" objects window

I somehow managed to “maximise” the objects window, so it fills all unused
space on my monitor, and I can’t work out how to change it back to resize it.
Can anyone help me please?

you need to undock them, simply drag by clicking on the window title (e.g.
Objects), once you move it away, resize controls are available again

I tried that, but I’m unable to drag it in this case. I can still drag the
other windows, just not that one.

Hello @RoscoHead , You can try to disable the Smart Docking System and try
again

In the last case, you can
also reset the Devmode settings :

Regards,
Boris

Thanks! Interestingly, Smart dock mode was OFF, switching it back on enabled
me to drag the window’s title bar & reposition it. Weird, but at least it’s
working how I like again!

I am having the same “un-maximize” issue, only none of the above works for my SDK ver 0.21.1. All of the editor windows do allow horizontal sizing, but vertical size remains fixed. i.e. no resize handles. I had all the editor windows sized and positioned perfectly until today when I made the mistake of clicking on “restore to default”. No matter what I do, I can’t drag or resize the editor windows. I have even edited the imGUI.ini file which seems to be where all the sizing and positioning info is kept. No use. The program even overrides my edits and rewrites the imGUI.ini file with default settings. Smart Dock has no effect for me either.

Hello @55tom55,

Can you show us with a screenshot please ?

You can try deleting the imgui.ini file located at C:\Users\YOURUSERNAME\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\LocalState\

After doing so, run MSFS again to see if the issue is resolved.

Please let me know how it goes.

Regards,
Boris

Hi Boris,
I have attached a screenshot. I tried what you suggested and deleted the imgui.ini file. However, mine was in location C:\Users\YOURUSERNAME\AppData\Remote\Microsoft.FlightSimulator.
The Project Editor and Material Editor float, but the Scenery Editor, Inspector, Properties, and Gizmo screens are all locked and only expand / collapse in one direction. Needless to say, this makes an SDK editing session VERY slow and frustrating. I appreciate your help.

PS: a clue. I left the editor screens in a certain position, and then exited the SDK. Then I deleted the new imgui.ini file it created. When I restarted the SDK it remembered all the editor screen locations! Where else are these being saved ???

-Tom

Your folder path seems incorrect. I guess you have a steam install.
Try using: C:\Users\YourUsername\AppData\Roaming\Microsoft Flight Simulator\LocalState\ Additionally, you can use the Windows search feature to look for the file named ‘imgui.ini’. The ‘Everything’ search engine from Voidtools is also excellent for this type of search.

Hope it helps,

Regards,
Boris

Thanks Boris. In my Steam installs the imgui.ini file only lives in the one place.
However, I did find a solution: I have another computer for testing betas. I copied the imgui.ini file from there, and presto! I can drag and resize all the edit windows wherever I want. In my case I like to have them all open on a 2nd monitor. Lesson learned, be careful with that “restore to default” button.
Issue closed.

1 Like