Multi-Exporter unable to generate XML File

I’ve just upgraded to Windows 11 on a production rig. 3dsmax 2022 installed
with the latest SDK. I’ve got Multi-Exporter window open and I’ve got a test
object with an export path set. Exporting the object works. However it’s
unable to generate an XML. There’s no error message, it just doesn’t generated
an XML when clicking Generate XML. This has always worked fine in the past so
I’m not sure what the issue is?

Same thing for me. Doesn’t generate XMLs, doesn’t export any files either. Max

Hi @pyreegue , Are you on windows 11 too ?

Yep, I am.

Thanks for reporting This issue will be investigated Regards, Boris

I’ve found some issues with the Multi-exporter, the option to create a Options
preset doesn’t work very well. Pressing the + button to create a new preset
returns a python exception “dict object has no has_key attribute”. I had a
look a the .PY source code, and it seems the has_key has been replaced with
contains in Python 3. I got rid of the exception by changing it. Pressing
the - button doesn’t do anything. Looking at the source code, in fact, it
doesn’t seem there is any code attached to the - button, so it doesn’t seem
possible to remove an option preset. This also raises a question: When
exporting animated objects by separating the multi-LOD meshes from the
animations, is it required to set the “no animation” option, assuming only
layers containing static mesh are exported ? Is the opposite true ? It is
required to set to export “animation only”, when exporting the animation
.gltf, assuming only layers containing animated nodes belonging to animation
groups are exported ? I’m asking because I’ve noticed that even when exporting
only layers containing static meshes, the resulting .gltf is still quite
large, even if nothing animated is being exported and even if the meshes are
just 100 polygons or so, just because the exported is flagged to export the
animation. The only way to create a smaller .glft for the lower LODs is to
explicitly set to not export the animation,. is this how’s supposed to be ?
Basically, when a multi-LOD object contains animations in a separate file, so
only layers with no animations are exported, does the export animation must be
enabled or not for the static meshes ? If yes, it would then be quite useful
if the save Options preset function would work.

Resolve Unique IDs doesn’t always work either.

Update - Still doesn’t work with SDK v0.19 - This makes exporting large amount
of objects very laborious.

@Boris Has there been any progress on this. This bug is absolutely killer for
large scenes with LODs. It really is a problem. Just FYI I’ve found that it’s
not isolated to Windows 11, I’m back to Windows 10 and same issue.

Hi there, We are currently reviewing all of our Python tools which have issues
under Max 2022 - these are due to the switch from Python 2.7 to Python 3.7
indeed (which happened between Max 2020 and Max 2021).
We will update the SDK as soon as the reviewing pass is completed. Best
regards, Eric / Asobo

Hi @EPellissier , thank you for the update,

Looks like issue has been resolved in the latest SDK 0.19.1 Thank you!