SDK 0.18.0 not downloading. I click on the Download button, but get no response

I’ve tried both the SDK Available option on the right hand side of the Devmode
menu as well as all the download options on the Help menu. I just get no
response from any. I normally work in FullScreen mode, so I tried Windowed
mode but this made no difference. I have successfully downloaded SDK many
times in the past. What do you suggest I try please?

Hi @JohnVulcan Maybe it’s a temporary server side issue or you should try by
set a different default web browser and try again. Also it could be a firewall
/ antivirus action which prevent to open the browser Regards, Boris

Looks like I’ve found the solution Boris, thanks. Initially it looked as
though it was to do with monitor size as I had been trying to download from a
5120x1440 monitor (my pride and joy!) with MSFS 2020 set at full screen, but
then resized and tried from my 1920x1080 secondary monitor and the download
worked straight away from the downloads window from the ‘SDK Update Available’
button. Further testing showed the problem was still persisting when trying to
select the other downloads from the Help menu. However, when attempted from a
third monitor (1920x1080) which is connected directly to the PC motherboard
using the onboard Intel graphics (the first two monitors are connected to my
Nvidia 2080 Ti card) the problem was resolved. Is it an Nvidia driver issue?
My driver is PS: My browser is Microsoft Edge.

Hello @JohnVulcan , Thank you for your feedback :wink: Indeed, this is not a
normal behavior and we will investigate this Regards, Boris

i needed to change the default browser from Chrome to IE for the SDK to
install. Weird!

Yes weird indeed! Looks like Asobo need to check that their dev mode task bar
is truly independent of browser type, monitor size, video driver etc. because
it doesn’t appear to be so at the moment.