Services".spb" file is causing a crash

The following services file, compiled to SPB as part of building my airport
(KASH) in SDK 20.5 is causing my airport to crash while loading after I select
Fly, before it reaches the animation of the airport before you actually enter
your plane. Interestingly, the same services file, in xml format, when used
with a version of this airport compiled for version 1.18.15, does not cause a
CTD. Also, if I replace the SPB file with the xml version, the SDK 20.5
version doesn’t CTD either while loading. I can’t find any misspellings or bad
formatting in the file. Another related problem I’m having is, both with and
without this Services file (located at AirportServices\KASH in the package),
and with both the 1.18.15 version and the SDK 20.5 version my airport no
longer has the option to call for a fuel truck from ground services. This is a
recent problem, it has worked in the past. I have two fuel truck spots, both
connected to vehicle paths running around the airport and to the taxiway
network. Since it doesn’t work even using the default Services configuration,
I’m wondering what to look for in my airport that might be causing the fuel
truck problem. I do see fuel trucks running around my airport.

Thanks for looking at this.

Hello @FlyingsCool I ran some tests with that xml content but did not
encounter the crash. Can you either provide us with a full dump file or your
package so we can have a look? Detailed instructions here:
crash/77) Regards, Sylvain

Yes, I realized this morning, as well, I didn’t test it with an “empty”
Community directory either to make sure I’m not interfering with another
community package, and I’ll do that as well. As I noted, it was only when it
was in SPB format that it causes a crash, I’ll attach that, too. Thank you

So sorry for wasting your time. The files work fine with an “empty” Community
directory, there is another package that is interfering. I’ve found several
packages with poorly formed Services files and fixed the lack of Fuel
Services, now I’m searching for the addon causing the crash… btw, the dump
is 18 GB, would you really want me to send that to you? Is there a way to
reduce it’s size?

Hello @FlyingsCool You can compress it using an archive tool. It’s up to you
but if you send it to us, I might be able to help identify what’s causing the
CTD and hopefully make it so it doesn’t trigger a crash anymore. Regards,

1 Like