Strange Editor behaviour - Objects are loaded before asset group is loaded

A strange problem is driving me crazy since a few days. I am working on a
scenery airport. There are some objects that it is obviously my own custom
object but I cannot select them cannot delete them. I cleaned up my community
folder. If I go to the default airport the objects are not there. And here
comes the strange part. When I load the project some objects (queiet a lot but
not all) are loaded into the sim immediately even before I load any BGL asset
pack with the editor. Earlier it never did load any object before the bgl
asset group was not selected and pushed the “load in editor” button. The
particular object that I am looking for is also “pre-loaded”. But I cannot
find it in the list. I tried to open the xml file with notepad and it does not
include it either. I have created several clean package and build package but
no luck. What do I miss here?

@Darwikey Does that ring any bell?

Maybe a package that contain these objects has not been cleaned

The package was several times cleaned with Clean All and Build All. No other
package includes those objects that are loaded prior the asset group load.

Did you tried the debug lod tool ? You can see the package name of scenery
objects, it can give you an hint…

Dear @Darwikey I have checked it is coming from the same package I want to
open. Screenshot was taken befor clicking on the “Load in Editor” Button. That
BudCargo Building is our custom object.

Sorry but this still creates us a lot of problem. Has anybody experienced it?
I have cleaned the projects several times but there are still objects before
Load. It is driving me crazy. Is there anywhere temporary files that I should

Sorry to bring this up again but still the issue is the same… Any idea?

@Darwikey An issue with cache files?

I don’t think so, but @tsgucci you can try to remove your content.xml file

Dear @FlyingRaccoon! I need some help. I still struggle with this thing. I
have deleteted the entire content of my community folder, deleted the
_PackageInt in the packages, tried to find anything in
\AppData\Local\Packages\Microsoft.FlightSimulator_8wekyb3d8bbwe\ but could
not. Was checking the VirtualFileSystem, Packages but could not find anyting.
Tried to clean the package hundred times no luck. My colleguae used the same
package as I did but for him nothing is pre-loaded. Almost all the objects are
loaded before loading the asset group. When I load the asset group some
objects and projected meshes are duplicated, the whole thing is a mess and I
cannot work in it.

Additional info: If I delete the compiled package from the project the objects
are not pre-loaded, so in my opinion the objects are not loaded from somewhere

Hello @tsgucci, In order to better understand what is going on, can you send
me your project, please? Regards, Boris

Hi Guys! Sorry for the trouble, it seems I did something what solved the issue
but I have no idea what. It seems that pre-loading the objects is a normal
thing, the duplication however was very annoying. I checked the default
package location cache. Deleted all the content from the community folder. In
the project itself the _PackageInt needed to be deleted. Interestingly there
is a folder with the same name as your project but in the root folder of the
project. It contains only the textures. In the project Packages folder the
same exist but with BGL’s and simobjects. This seems to be a duplication. I
deleted all of this, rebuilded the project the duplicated projected meshes are
fine now.

I reported this bug a while ago:

Yes I have seen that. It is not yet fixed unfortunately.

I have a very similar problem. Some of my objects in the project are loaded in
duplicates but there is just one of them in the list. I would not even know if
I didn’t decide to move one of my objects a bit to the side just to find out
there was another completely identical one right inside it. If I delete the
movable one (which is in the list), I can’t do anything with the one left in
the scene. If I build the project like this and reload it - there is no object
in the scenery at all. Weird thing is that it happens only with some objects
that were added with earlier versions of the SDK, it doesn’t happen with the
objects added in the current version.

Hello @ZdenniZ , Is your community folder empty ?
Can you please send me a screenshot of your root project ? (where they are
Packages, PackageSources folders etc) You can try this: 1. Close your project
(‘Project Editor’ window > ‘Project’ menu > ‘Close’) 2. Go to your project
root folder and delete _PackageInt / & Package / 3. Open your project
but don’t click the button “Load in Editor” in the inspector →
just click on “Build All” 4. Once the build is finished, you should be able
to click and load your BGL via “Load in Editor” Best regards, Boris