[SU14] Beta - .18 - Flaps - system_type_index not working

Version: *SU/AAU/WU XX -

Frequency: Consistently*

Severity: High

Context: Building aircraft.

The system_type_index if set to 6 when the system.cfg flap motor circuit is

circuit.6 = Type:CIRCUIT_FLAP_MOTOR		#Connections:bus.1	#Power:0.1, 0.1, 20.0	#Name:Flaps_Motor ; Flaps motor



;; 10 degrees = 0.175 rad   40 deg is 0.70 rads

The flap system will not work - flap simvar will not change.

work around, set back to zero works.

Repro steps:


Private attachments: Send a PM to @PrivateContent with the link to this topic and the link to download your content

Hello @DA40CGDFQ

I need to have this confirmed but I think the index it refers to is not the cfg line one but the circuit one.
So if you need 6 flap motors circuits, they need to be defined like this:

circuit.51 = Type:CIRCUIT_FLAP_MOTOR:1					#Connections:bus.2#			Power:200, 240, 20.0#		Name:Flaps_Motor1 ; Flaps motor
circuit.52 = Type:CIRCUIT_FLAP_MOTOR:2					#Connections:bus.2#			Power:200, 240, 20.0#		Name:Flaps_Motor2 ; Flaps motor
circuit.53 = Type:CIRCUIT_FLAP_MOTOR:3					#Connections:bus.2#			Power:200, 240, 20.0#		Name:Flaps_Motor3 ; Flaps motor
circuit.54 = Type:CIRCUIT_FLAP_MOTOR:4					#Connections:bus.2#			Power:200, 240, 20.0#		Name:Flaps_Motor4 ; Flaps motor
circuit.55 = Type:CIRCUIT_FLAP_MOTOR:5					#Connections:bus.2#			Power:200, 240, 20.0#		Name:Flaps_Motor5 ; Flaps motor
circuit.56 = Type:CIRCUIT_FLAP_MOTOR:6					#Connections:bus.2#			Power:200, 240, 20.0#		Name:Flaps_Motor6 ; Flaps motor

and if you want a particular flap section to depend on your 6th motor, system_type_index can be set to 6 (and not 56 in my example).

Note : you will need to have 6 flap motor circuits defined for this to work.

I have noticed some aircraft have this parameter set to the line index but I think this is a mistake. I will have this reviewed and confirmed.
In the meantime, try what I suggested and let me know if that solves the issue.


Thank you - then I believe you should change the wording in the text to

Circuit Type, not just Circuit.

Issue resolved

Please review any other SDK documentation that refers to Circuit , when it should refer to CircuitType index.

1 Like

Sure, we will review it and make it more explicit where appropriate.

1 Like

To add my €0.02 to this, Iif I specify the flaps as electrical and have a flap motor circuit, it will work correctly with index set to 0.

I have tried adding a circuit index for our plane, but the flaps never worked.

@SWS-AlexVletsas It will not work if you don’t have existing circuits defined with the previous indices.

I do have a flap motor circuit, but it wouldn’t work. Will retry and LYK.