Why the aircraft model will first read the default ILS frequency instead of the ILS frequency I set?

In China, if I do not use Navigraph data but use the default navigation data,
the ILS of many airports will be offset. Therefore, I built a new airport
myself and created a new ILS in the correct location. However, the airplane
model reads the default ILS instead of the correct ILS I set. Unless I set the
wrong frequency ILS and input the wrong ILS on the airplane model, the model
will intercept the ILS I set.

Have you tried enabling deleteAllILSs in airport properties for your addon?
That should disable the default ILS.

I actually have issues with this as well and have reported it through zen
desk. even using the Delete all ILS command, the default ILS is the one the
airplane follows

I also confirm. I have the same problem with my airport. Despite having set
DeleteAllIls to true, the Default one remains present and is the only one
working (which also has an incorrect course, since in reality it should have
an offset of 2 degrees). I also discovered by chance that by setting a wrong
ID to the ILS also mine appears on the map. I am putting you the link to the
post I opened on the official forum with the description of the test I did.
su4/407477> I also made a report to ZenDesk.

I replied to your forum post. I had no problems replacing the ILS at that

I confirm the problem. DeleteAllILS command doesn’t work and I’m unable to
exclude default ILS.