Aprons in DEV mode "Your graphics device had encountered a problem and MSFS will exit...etc"?

Anyone else getting the “graphics device … problem” then CTD ( that many are
reporting in normal flying) seeming to come on very frequently when working
with Aprons since SU10 ? Very much like the previous “memory could not be
read/write” crash when working with Aprons. Almost like its the same crash
just a different dialog box.

Hello @CIAE985 , It seems related to what we are talking about in [this
about-device-removed-ctd.html). Would you be willing to help us debug this
problem? :slight_smile: What GPU are your using ? In what timezone are you located in? Can
you follow the process in this attached document and send us a .nv-gpudmp and
the dmp file ([see 2) Generate dump files to help diagnose and fix
or-crash.html)) that will be generated after the crash please ? Regards, Boris

@Boris Certainly happy to help. I have an RTX3090 GPU and Timezone is GMT
+10. Will read the information on the dump files and send them on this post.

Thank you :slight_smile:

I'm having the same problem as my friend. I can't add an apron or edit it, the message appears and the simulator closes. I also noticed a bug related to the textures of aprons that we have to drag the material to its properties.
I have an xfx RX6600 8gb running on DX12 drive amd adrenaline 22.9.2. I don't know how to generate this dumpcrash by amd.
[Microsoft Flight Simulator_2022.10.14-11.00_1.png](upload://bgRN3i7E9eIxzArc2fYtM3qWMiV.jpeg)

@Boris Have set up the Nvidia GPU and Windows dump files. Crash only took
about 5 minutes in Devmode working on Aprons , so I can reproduce easily.
Onedrive link will be sent to moderators and myself only.: Now that I’m set up
, I will capture a few more dumps as they appear.

Same issue as well, but not related to aprons, just happens in devmode
occasionally. Equipment is RTX3080. Never happened before

Sometimes even during initial loading

I just had this same issue and never had it before. Happened as soon as I
clicked on “Load in Editor” for my airport project BGL. I’m currently using
SU11 and the SDK 0.20.1 I tried several times and every time I loaded the
editor with my parking spaces in view (there’s only 4 of them and they are not
connected to anything yet) it crashed. If I spawned in on the runway and
loaded into the editor it worked fine and I could make changes. I also tried
again spawned into my parking spots and moved the dev camera away from looking
at the parking spots and when I loaded into the editor it again worked fine.
But if I load into editor at the parking spots with the spots in view then I
get the graphics card crash message. I’m using a GTX3080Ti card.

Sometimes can’t even load the scenery. Have to perform a full PC restart and
then there’s a 50% chance that it will eventually load.

Yes I will occasionally get the crash loading the scenery, but mostly in DEV

@Boris Please confirm you can access my Onedrive folder link. I can bring on
this crash within minutes usually and have generated 5 dump files from Windows
Error Reporting for you. (As mentioned already, eerily similar to the “memory
could not be read/write” error pre SU10 that was present for months.) Only too
happy to produce more dumps, so let me know. Interestingly , all crashes are
generating Windows Error files not Nvidia GPU Debug files (apart from GPU
files that look like initial setup stamps). Rob

Hi @CIAE985 , The team was able to access your Onedrive folder. They are still
investigating this issue and we will let you know if we need more informations
from you :wink: Thank you, Regards, Boris

NVIDIA RTX 2080Ti, Game drivers 517.48 and 522.25, Win10 (updated), UTC-4
(US/NY), MSFS in DX11 mode: Same kind of crashes (same alert message)
constantly, sometimes before the flight even starts and the GPU fans spin
up… sometimes a ways into a flight. No scenery or any other editor open,
though Dev Mode is active (didn’t think to try w/out it). Reverted to Studio
driver 517.40
, no mo crashes. ¯\(ツ)/¯ FWIW I played a couple other games
(also obtained via XBox store) with the Game drivers which also crashed with a
similar message. Haven’t tried them again since reverting to Studio. -Max

Max is this still working for you ? I’ve never tried the Studio drivers and
just gave 517.4 a ago on my RTX3090 . Unfortunately my first crash took 32
seconds and the second crash was a little under 2 minutes. Also lost 30% of
FPS, so its back to the game ready drivers for me. Rob

Hi Rob, just had a nice flight up high in New Zealand… the weather was
choppy but otherwise uneventful. :slight_smile: So yea, still seems to be fine after
several startups… other things running in the background… pretty smooth. I
don’t watch FPS counters so I don’t know what the numbers say… the visuals
and controls are smooth, maybe the smoothest yet so far of all the MSFS
versions. Haven’t tried DX12 again with this driver + SU10, though previously
that was a lot less stable than DX11. From what I understand from NVIDIAs
marketing speak (and some experience), the Studio drivers are basically an
older/more stable version of the “Game Ready” drivers which get a quicker
release cycle and therefore quicker updates for latest games/apps, albeit at
the risk of introducing new issues. I do more video production and programming
than gaming and usually just run the Studio version… and all the games I do
play have run smoothly enough for me with the 2080Ti on “ultra” graphics
levels. Anyway, I didn’t really expect this to be “the answer” since such
things are going to depend on many possible factors. Just throwing out what
worked for me… the sim was essentially unplayable here on the newer Game
drivers. I will not be offended if you “un-accept” this post (if that’s even
possible)… :slight_smile: Cheers, -Max

@Boris , I want to disable the WER dumps ( my machine runs very slowly for
several minutes after every crash while it writes the dumps). Do I simply go
into the Registry and delete the FlightSimulator.exe folder under “LocalDumps”
? (Also noticed all the NVIDIA folders have disappeared under “LocalDumps”
…) Happy to do more dumps if required in the future Rob.

Thanks Max, appreciate all input . Glad you had a nice flight :slight_smile: As you say
maybe the studio drivers will help others get around this while an official
fix is developed. BTW , I think I accidentally “accepted” your answer and just
fixed it now - still learning these forums . Hope you have crash free flying.

Hello @CIAE985 , sorry for the delay, Yes you can disable the generation of
dump files by deleting the corresponding reg key Thank you for your time,
Regards, Boris

Success ! Inspired by @max.paperno , I tried
messing with graphics drivers and whilst the Nvidia studio drivers did not
work for me (RTX3900) , Geforce RTX 522.30 seems to have completely removed
this crash for me. I’ve enjoyed several DEV sessions 30 minutes plus which
haven’t been able to do for several months. Rob