CTD on Marketplace Build/Export

Has anyone ran into any issues with a Build & Export for Marketplace causing a CTD (in the past or recently)?

I have been working on a few updates over the weekend here and had no issues exporting for PC/Xbox for two of them, however the 3rd one crashes MSFS every time I try to export.

I have done a clean all and the package (and marketplace data) does build successfully, however as soon as it is done building and moves on to the export/packaging part it immediately crashes. It has done it consistently every time I have tried.

The package changes were relatively small. Just a few updated gltf’s. All is seemingly well there. I did update the marketplace description, but it was just some re-wording. Text only. It’s not over the character limit or anything.

Not really sure what is causing the crash or how to go about debugging it, beyond rolling back changes and doing clean builds to see if it eventually works. Though, I would think if it was an issue with a file, it would show in the build process and not the export/packaging.

Any ideas? (I’m not on the SU15 beta)

Hello @Rotornut44

We didn’t have the issue with the few sample projects we export on a regular basis.
But if you file a bug report and provide us with your project and dump file, we will investigate.


As I mentioned, it’s only this project doing it out of a few I have tried, so it has to just be something it doesn’t like that has changed since the last time I exported a package for Marketplace.

I’m going to try to debug it some more on my own here later today, but just in case I still don’t figure it out, exactly which dump file do you want?


OK. It started doing it with just the Build package option today as well (only on the same project), so I broke the package all apart trying to narrow it down to an individual file with no luck.

I eventually found that disabling all of the community scenery addons in the region stopped the crashes. I did several exports to verify.

I then tried to figure out which addon was causing the issue and eventually got it narrowed down to a consistent 5. Enabled each one of those 5 individually and had no crash. Enabled all 5 again and had no crash (wut?). Enabled all of the addons again and the crashes come back. I cleared my scenery indexes every time I would disable an addon, for good measure.

So, the issue doesn’t seem to be related to any one addon, but multiple addons. And it is only affecting this one scenery when I try to build.

What is even going on here? Luckily I know how to export the package now, but I think there may be a bigger issue going on here. Will see if I can narrow it down any more at a later date in case the 5 were just a fluke, but for now I need to move on.

Ok, the dump file will help then.
Follow steps 2 and 3 of these guidelines: How to report a bug or crash - Bug Reports - MSFS DevSupport (flightsimulator.com)


File sent to private.

Hello @Rotornut44

This is a crash we are already tracking in a different context. It is related to how BGL file are loaded.
I’ll forward info about your specific case to the devs to help diagnose the issue and we will let you know if we need more feedback.

Thank you for reporting the problem.


1 Like