Fspackagetool.exe, missing compilation information on beta Sim update VI

With the update VI at the end of the compilation of a project with
fspackagetool.exe I no longer have the compilation information. Before the
beta VI update, this information was present, I don’t think there is a switch
to enable verbose mode. Is there any way to do this? Thank you.

Missing this too. Would love to have it back.

Also in official SU6 release it’s missing. Can this get fixed?

Really frustrating, to know if the compilation was successful we have to wait
4 minutes to load the simulator, calculating that I compile dozens of times a
day …

Hi there, Apologies for this issue which is under investigation on our side -
could you please specify if you are using the MS Store or Steam version of the
Sim? Best regards, Eric / Asobo

+1’ing this issue. SU6 installs - packagetoolkit doesn’t do its job. Just
holds black CMD prompt and flashes off. I assume with new SDK files it will

+1. The package is correctly built, but the build window does not appear. So
the compilation infos are not visible.

+1 with MS Store, all default paths Windows 10 if that matters (Never been in
Beta) Blank Window for fspackagetool, no messages, no prompt only a blinking
cursor, even forcing an obvious error (wrong paths) still no messages package
Is Indeed generated (and i’m making sure that the packagetool Is doing its job
by deleting _packageInt and any Packages folder) Really annoying :confused:

MS Store for me

MS Store!

+1 Steam, all of the above - no console display (no window at all), build
process completes but doesn’t prompt completion so cannot use

A couple of work-arounds here as a batchfile and a ps1 powerscript:

+1 for me. Steam and Store… And if I build a project from the sim I lost
half of my custom objects. Helps only restore XMLs from backup. Thank you
Asobo for breaking those things that worked!

Unfortunately, even if i already tested by deleting the temporary build
folders, with the alternative command line to build packages, still the same
result for me: no budling window logs (and i have the Steam version).

Steam for me

Steam for me

Steam for me

NO!!! It’s not working all times. In my case there are mods that can
successfully be build but others don’t even create the json files or buiness
without changing anything. The built inside of MSFS creates the messages
successfully on the console (dev mode). Why is the SDK update so late???

Store, Game pass


      1. Remove-Item "D:\MSFS_Projects\LakeLawnAirport\_PackageInt" -Force  -Recurse -ErrorAction SilentlyContinue Remove-Item "D:\MSFS_Projects\LakeLawnAirport\Packages" -Force  -Recurse -ErrorAction SilentlyContinue 
  2. D:\Programs\Steam\steamapps\common\MicrosoftFlightSimulator\FlightSimulator -I ";" BuildAssetPackages "D:\MSFS_Projects\LakeLawnAirport\AirportProject.xml" "D:\MSFS_Projects\LakeLawnAirport" "D:\MSFS_Projects\LakeLawnAirport" 
  3. pause