Photogrammetry outside published World Hub airport KMTH disabled when it shouldn't be

Regarding: World Hub website/DevMode/Airport/Other
Airport that was edited in the World Hub, but is now published

Frequency: Once/Rarely/Frequently/Consistently
Only been to the airport once

For DevMode bugs, please include the game version: SU/AAU/WU XX - 1.XX.XX.X
SU 15 beta 1.37.17.0

Bug description:
If you visit Florida Keys Marathon airport (KMTH), you will see that there is no photogrammetry outside the airport. (See “Attachments” section.)

This is an airport that was edited twice in the World Hub.

This was first observed by @sarpouli (post) and then corroborated by me.

Looking at it in the World Hub, I can clearly see an airport polygon around the airport, excluding TIN. I traced around it and don’t see it flying off in some random direction: It appears to be properly placed around the airport. (See screenshots 3 and 4 in the Attachments section, below. And you can also see the polygon’s properties in the last screenshot.)

Repro steps:

  1. In your settings, ensure that online functionality and photogrammetry are turned on.
  2. Start a flight at KMTH. (I observed this in SU 15 beta 1.37.17.0. I cannot speak for sarpouli.)
  3. Use the drone/showcase camera to look around the perimeter of the airport.

Expected result:
There is photogrammetry immediately outside the airport.

Observed result:
There is nothing but textures just outside the airport. No autogen procedural buildings or photogrammetry. (See first two screenshots, below.)

Attachments:

Here are two screenshots just outside the published airport in SU 15 beta without dev mode turned on. (If it’s not clear, there are just textures on the ground. No photogrammetry or other buildings.)

Here are two screenshots showing the airport polygon highlighted in purple:

(I couldn’t help but show a boat crossing over the airport in the second picture :smile:. But in all seriousness, you can see the airport polygon just behind the boat.)

This is the airport polygon around KMTH:
image

1 Like

Thanks. I will shortly share an in-sim screenie depicting the terraforming rectangle that causes the problem around KMTH (data all stock and default and no mod at all / update: was actually modified thru the World Hub process)

1 Like

here is the faulty terraforming rectangle :

It’s hard for me to tell in that picture…is there no photogrammetry inside that rectangle? And is there photogrammetry outside of the rectangle?
I’m trying to understand if that rectangle is the exact boundary where the photogrammetry stops and starts.

It’s not a triangle it’s the big rectangle in yellow with dot meshes inside. Inside that reactance is no TIN. Outside the rectangle starts TIN to appear back. Therefore it’s the exact boundary of the terraforming rectangle that spoiled the TIN.