Repeatable Simulator Freeze Only with Release WASM


Recently, we discovered that our WASM causes the simulator to completely freeze upon loading. The loading screen finishes (usually) and you’ll get the first second or two of simulator visuals, then it’s a complete freeze. Sound continues, but no interaction or redrawing.

This only occurs with a Release mode WASM. WASM Debug Mode in the simulator itself makes no difference. The exact same code works as expected in Debug mode, and works correctly in both Release and Debug when compiled in x64 (for our standalone environment/P3D).

Some of the recent changes included large data allocations and AI traffic data acquisition, both of which I have tried removing to no avail. Since this problem began, I have been 100% unable to use a Release-built WASM without disabling enormous (and previously working) sections of code (reducing the aircraft to an unflyably-simplified state).

I’d be happy to provide a WASM and activation key for the product to an Asobo developer to help us identify and resolve the issue. I can’t post them publicly for obvious reasons, but will provide them via DM.

I have tried with SU14 and SU15 beta and the results are identical. My SDK is up to date and I am compiling from Windows 11 and Visual Studio 2022.I have also had another developer on a different machine test and he experienced the same results.

Thank you in advance,
Collin Biedenkapp,
TFDi Design

1 Like

Hello @turbofandude

Please follow these guidelines to send a package that we can investigate:
How to report a bug or crash - Bug Reports - MSFS DevSupport (


Understood - report opened here: Repeatable Simulator Freeze and/or Crash Only with Release WASM - Bug Reports - MSFS DevSupport (