Scenery Editor CTD

We encountered this problem which is really slowing down development of
airports. The bug happens as follows: Package built with the
fspackagetool.exe and copied to the Community folder
, editing/moving nodes
in the Scenery editor will quickly result in a CTD, very quickly after a few
edits. The operation that seems to trigger the crash more frequently, is
dragging the mouse to move a TaxiwayPoint node, especially if it has two or
more paths connected to it. This crash is repeatable, and we tried it on 3
different PCs, all of them in 100% default installation with nothing else in
the Community folder other than the scenery we are working on. If the
Community folder is empty, (
only copy of the scenery active is the one
mounted on the fly by the editor itself), seems to fix the CTD when editing
nodes but, there’s another bug: Projected Meshes disappear in chunks when
raising the Developer camera, and they never reappear, regardless if we go
back down to ground level. Even clicking Show/Hide buttons on the Projected
Mesh objects doesn’t make them to show up. This makes working on an airport
almost impossible because we clearly need the Projected Mesh to be visible in
order to create matching Taxiway Points and Paths, but it disappears if the
scenery is not already there in the Community folder, which in turn makes the
sim to CTD after editing a few nodes. Removing both the _PackageInt and
Packages folder from the project folder to trigger a complete rebuild ( both
externally with the fspackagetool.exe and from the “Build” button in the
editor ) doesn’t fix the problem. The Console doesn’t report any error, like
missing textures or anything else, related to our package, both at load time
and while editing too. FYI, the airport contains 3 Projected Mesh objects. I
mentioned because, a long while ago, one Sim Update caused airports with more
than 2 Projected Mesh to disappear and crash the editor if edited. This was
fixed long ago but, who knows, maybe there’s a relationship.

These are the error details, maybe it could be helpful. Note that, the crash
happens always at the same offset, 000000000103ce37

      1.  FlightSimulator.exe 
  3.    00000000 
  4.    FlightSimulator.exe 
  6.    00000000 
  7.    c0000005 
  8.    000000000103ce37 
  9.    2cb4 
  10.    01d79ac4d97d9840 
  11.    C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.15.0_x64__8wekyb3d8bbwe\FlightSimulator.exe 
  12.    C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.18.15.0_x64__8wekyb3d8bbwe\FlightSimulator.exe 
  13.    e3148cb9-3151-425d-9bee-f488302964dc 
  14.    Microsoft.FlightSimulator_1.18.15.0_x64__8wekyb3d8bbwe 
  15.    App

I would really like to have some answer from the devs. This bug is so serious
that it makes working at airports almost impossible, requiring too much time
to edit, due to the continuous CTD every few minutes, requiring a long restart
each time. I managed to reduce it a bit, using the following workaround: - I
compile the scenery externally with the fspackagetool, and place it in the
Community folder - Before starting the sim, I remove the airport BGL ( the
one that has all the taxiways nodes/paths ) from the scenery folder and I edit
it out from the layout.json file too. This allows to fix the disappearing
Projected Mesh bug when a scenery not already present in the Community at
start is loaded in the editor and seems to have increased the time between
CTDs from a minute to 5-10 minutes. But still this should really be looked at,
because the Scenery Editor is simply too unstable to be usable in its current
state, and one shouldn’t go through these time consuming hoops to begin with.
Also, since the CTD is unpredictable and can happen any time every 5-10
minutes, it increases the number of clicks required to edit an airport, since
now I’m forced to press the SAVE button each time after a single edit, because
it’s impossible to tell when the next CTD will strike. Note that, I’m trying
to keep the external interference as low as possible so, I don’t have anything
else in the Community folder, I have the rolling cache disabled, I disabled
ALL traffic ( AI or Human ) and I keep the weather as Clear Skies preset. The
most dangerous operation definitely seems to be MOUSE DRAGGING any object,
regardless if it’s a node or a parking. That’s when the chance of a CTD is

The disappearance of the projected mesh has been happening since the start of
testing with SU5. Myself and other developers have already reported this
problem several times, I gave a copy of my project with this problem to
sylvian so he could see it for himself and this is what he told me:
@FlyingRaccoon : I’ve reproduced the
rotation/scale issue with your package and our scenery editor dev has this bug
in his todo list. My problem goes beyond simply disappearing, the projected
mesh in my case does not appear the real size, it appears very small and it is
necessary to rotate and enlarge the image a lot so that it can fit with the
real size and this is impossible because after a few seconds it disappears. I
have not had any more feedback on this problem, so I can not know at what
point they are now, if we will have a solution to this problem soon or not.

CTD problems is something that I also have time experiencing, in my case is
unpredictable and can occur at any time when you want to move any object, the
simulator just freezes and closes.

I can confirm CTD with the same exception code, this CTD always followed by
.NET Runtime error, hope to believe that is a temporary issue caused by all of
SU5 faults in part of scenery editor best

A few minutes ago, I had the fastest crash ever: - Loaded the sim. - Started
at the airport. - Loaded the project. - Went to a parking to fix its
rotation and, as soon I dragged the mouse to rotate the parking, got the usual
CTD at the same Offset as I posted before. On the next sim startup, I got the
“60% load freeze” reported in other posts. On the 3rd startup, the sim loaded,
so I tried to rotate that parking again, same CTD. So, basically, I had to
restart the sim 3 times, without being able to rotate that parking. On the 4th
startup, I tried a different approach and, instead of trying to rotate the
parking with the mouse, I typed a different heading with the object Gizmo.
Tried to do this multiple times, until I found the right heading, getting no
crashes. So, it really seems anything related to MOUSE dragging ( whether it’s
moving or rotation ), triggers the crash. And in fact, after rotating the
parking, I added a new node by splitting a path and, as soon as I moved it
with the mouse, CTD again…

Hello. We’ve just identified and fixed a similar crash that is matching your
description. This CTD was identified through our automatic crash report so I’m
optimistic that’s the one you were having. The fix will be available with Sim
Update 6. As for the projected mesh disappearance issue, it will be fixed with
WU6. The rotation/scale bug is still being investigated. Regards, Sylvain

  1. The fix will be available with Sim Update 6

While I’m happy you seem to have found the cause of the crash, is a bit
disappointing hearing it won’t make it for the upcoming World Update 6. So, I
understand WU6 has already “gone gold” and it’s not possible to add any last
minute fix, not even in a subsequent Hotfix ? If that’s the case, what’s the
ETA for SU6 ? Will a Beta be available in advance like SU5 ?

FlightSim right now it’s really unstable. It’s a pain to work with it, please
listen us.

FlyingRaccoon, is there any temporary workaround to avoid\reduce number of
appearance of this nasty CTD? It’s very annoying to have constant CTDs until
SU6 will be released thanks

Hello, I’m really sorry for the inconvenience caused by this lack of stability
in the Editor. The SU5 and its batch of Xbox-related optimizations provoked
several bugs, some of them hard to anticipate considering the fact that we
don’t work with community packages. And even though some of you tested the
update in advance, and made feedbacks, we lacked time to fully investigate and
fix the bugs. That leaves us with a set of fixes embedded in the upcoming
World Update (it’s exceptional, usually we no longer push SDK or code changes
outside of the Sim Updates). And indeed the WU6 has reached gold status and
won’t be edited anymore. I’m not allowed to share the date for SU6, otherwise
I would have, but I’m sure Microsoft will communicate about it soon. And if
there should be a hotfix after WU6 (which isn’t my call to make…), the fix
mentionned by FlyingRaccoon would surely be part of it. But at the moment I
actually don’t know if we will publish one…

I wanted to report the CTD in the editor that always happens a in few minutes
after moving nodes or parking spots, still happens with today’s hotfix. Is
this this scheduled for a fix in SU6 ? Editing a scenery now is way slower
than it should be since: - It’s required to save after every modification,
since it’s not possible to anticipate when the CTD will strike (it can be in a
couple of minutes, but not always) - All continuous restarts will take time.
Note that, this crash doesn’t seem to happen if the airport is very simple,
with few parking/taxiways and no jetways.

Here’s a link to a mini-dump file:

Hello. Thanks but a mini dump will not be enough to confirm it’s the same
issue, we would need a full dump.

@FlyingRaccoon here’s the full memory dump,
I’ve enabled it using the LocalDumps registry key for FlightSimulator.exe,
with dump type = 2, hope it’s the correct one.

Hello. I can confirm that’s the same crash we just fixed for SU6.

Hi. I have the same issue I assume which I logged with Zendesk. I’ve been
redoing a complex airport YMML and have been placing taxiway lines, jetways,
stacks of scenery objects and finally, custom materials in tiny aprons as the
taxiway parking marks. I’ve now reached a point where if I try to add another:
I can place the apron and add the material but then the entire background of
the airport disappears and reveals the underlying satellite default
background. If I then rotate or move the apron a fraction (by mouse) it
reappears. I can then place it. Sometimes that then causes a CTD. Other times
I can compile (just with the one new apron) and the project edit causes a CTD
on close. The later CTD although having a successful compile causes the reload
of the new version to CTD after selecting to FLY from the World Map - half way
through loading. So basically I cannot add any more parking spot places but I
can edit existing scenery and lines

Good to hear. Now, we can only hope to be able to beta test it soon…

@FlyingRaccoon is it possible to review my above comment and decide if it’s
the same issue? In the logged case I supplied the Dev project and can do so
again if required. I’m basically at a standstill and don’t believe I’m doing
anything outside the normal. It just simply stopped allowing me to add any
more aprons with material-correction, I can add but as soon as I move it, a
CTD Zendesk 121706 which says solved but of course it’s not