SDK 0.16.0 after SU7 will crash to the screen

Hi. Iam owned Steam version of Flight Simulator. Reinstalled 2 days ago due to
SDK crash after SU7. It doesnt help. Version of SDK: 0.16.0. Simulator SU7.
Community folder is empty. I load to the airport which I would like to edit.
In settings set up the DevMode : ON. In DevMode open the project. Klik on
“bgl” and "Load in editor. SDK will crash the sim to the screen. Do you have
please any idea what can I do? I am a developer and this makes me crazy. I can
not working on my projects. Thanks ;}

Hi. I have Steam version. Can you share your project with me and I’ll see if I
can open it. I had issues too but they related to taxi points not being

Hi. Yes I know about the Taxi points. Now is problem, when I opened project
approx half year old. SDK will opened it without any issues. I fixed all
errors { including taxi points } and seve it. To this point SDK work great.
Issues will come, when I klik on Build Package. SDK will crash the sim on
screen. I dont know what can I do.

I had similar problems with the MS Store version of MSFS. Have you checked
your Windows Event Log, mine showed Exception code: 0xc0000005 errors (This
code is issued when an app attempts to read memory not allocated to it.).
Following SU7 I had a considerable number of taxiway points errors, which I
tackled by deleting them, however I believe the SDK Scenery Editor cannot cope
with large numbers of deletes made between saves and I suffered multiple crash
to screen issues. Decided to start again, but this time just changed status of
the taxiway paths from TAXI to ROAD which eliminated the taxiway errors. Even
so still had problems with Save Scenery. It did Save Scenery without giving
any errors, but it wasn’t actually saving to disk. Fortunately Rebuild All
recognised that no save had been done and successfully forced a save before
compiling the scenery. This seems to have done the trick, but really it is
still too early to tell definitively.

I am now having the same issues (STEAM). I get a CTD under the following
circumstances: 1. Click FLY and and use the INS key to view outside. I can go
up/down (W/F) but as soon as I use the numeric 4 or 5 I get a CTD. My GPU goes
for 90-100 to 0% and then CTD 2. Click FLY and use DEV mode. Load my airport
etc. Using the W/F/A/S/D keys same thing after a few seconds - especially near
scenery or models that are complex. If I touch the numeric keyboard arrows
(rather than the W/A/S/D) the CTD happens instantly. This has not been an
issue before SU7. I might also add that after 2 CTDs I seem to be able to last
a little longer before the CTD. 100% repeatable and rather annoying… For
what it’s worth…Exception code: 0xc0000005 Fault offset: 0x0000000001b1859a

Ironpot, when you first opened up your project in SU7 did you get a lot of
errors which prevented you from doing a Save Scenery? I had a lot of errors
and had to do a lot of edits before I could do a Save Scenery and I think the
Scenery Editor doesn’t take kindly to a lot of changes being made between
saves. I just wonder if our CTD problems stem from that.

I’ve got also terrible CTDs when trying to delete many faulty taxiway points,
couldn’t even get to save the scenery. Then, frustrated, I opened the xml and
manually deleted all taxiway points in the hope to redo everything from
scratch. Now when I am trying to redo all taxiways I still get CTDs and have
terrible devmode performance overall. Three CTDs were with the WWise dll, one
with CoherentUI dll, others just flightsim process errors. Normal flights are
completely fine, no CTDs whatsoever. Ready to tear my hair off my head. Using
the beta BTW. Dear Asobo (Alyzee, Sylvain), could you please comment on this?
This effectively stops all development.

Basically all my development (and flying) is halted. On clean builds with no
errors and all taxiway points etc fixed in the days after SU7 came out. Now
somehow, something has changed and constant CTDs when slewing either by
W/A/S/D or NUM pad and using INS key. This is true in both FLY mode and DEV
mode. In answer to you John, no my project was clean. In fact I reviewed all
my projects when SU7 came out and ‘fixed’ them. The only thing I have changed
are the NVIDIA drivers to 497.09. I might roll back. As mentioned, just before
a CTD the GPU plummets its load from whatever to zero…

Hello I wasn’t able to produce such CTDs yet when testing the Scenery Editor.

If those crashes happen on your scenery specifically, you can also provide me
with it and I’ll test your repro steps using it.

Regards, Sylvain

Hi guys. I tried to install Nvidia “496.76-desktop-win10-win11-64bit-
international-dch-whql” drivers, newest “Microsoft .NET SDK 6.0.100 (x64)” and
“Microsoft .NET Runtime - 6.0.0 (x64)”. Also I set the registry for Windows
Error Reporting. When I get the SDK error, I will provide error file from Dump

By the way, I tried
yesterday SDK in my new project. I mean after the SU7. And almost everithing
works good, except for “Painted hatched area” and my sustom textures. When I
want to create the “Painted Hatched area” I can, but nothing is displayed. And
my custom textures. I can create them. In the SDK I see them. But after
install package into the Community folder I can not see them into the scenery.
In the finish in SDK I click on “Save Scenery” - it works. And after that on
“Build package”. It works too, but the Simulator will freaze. I had to
Ctrl+Alt+Delete and stop the application manually.

> If you’re willing to, you can generate and send us a full dump file using
Windows Error Reporting
Is that something any add-on developer can do? Where
can one upload such dumps? I would love to be able to upload crash dumps in
case it helps in fixing crashes and making the program less fragile,
especially in Dev Mode… Sorry if one is not supposed to ask…

Hello Sylvain, I would like to make the following points regarding this CTD
issue:- 1) These CTDs did not occur prior to SDK 0.16.0 2) After the 0.16.0
update, my inexperience meant that there were many errors (100+?) identified
which had to be resolved before ‘Save Scenery’ would work. This meant many,
many changes had to be made before the first save could be done and I don’t
believe the Scenery Editor copes well with so many changes all made at one go,
especially when these changes are deletes. 3) For my first attempt at
resolving these many errors I deleted all the affected objects (Taxiways and
Parking) then did a save. This worked and I continued my development work ,
but after a few hours the CTD’s started, getting worse and worse as I battled
on. All were Exception code: 0xc0000005 errors. 4) I was forced to start again
(from my last 0.15.0 backup) but this time instead of doing deletes I changed
the state of the Taxiways from TAXI to ROAD and actually connecting the
Parking up to the taxiway. However I then had problems doing a ‘Save Scenery’.
It appeared to be working, but it was not actually saving the changes to disk.
Fortunately ‘Rebuild All’ recognised that no save had been done and forced a
successful save before compiling the scenery. 5) Following this second
approach I have not suffered anymore CTD, though in truth I think it is still
too early to tell if I have really resolved the issue. I will set up the
Windows Error Reporting as requested in case I do get more CTD. Regards, John

So I checked - my NVIDIA drivers installed last week when the CTDs started
happening were 496.76-desktop-win10-win11-64bit-international-dch-whql So I
decided to roll back to the version I had when SU7 first came out which is
472.12-desktop-win10-win11-64bit-international-whql by doing a clean install
of drivers (including sound for my screens) And guess what… no CTDs and all
the symptoms I described including slewing while in DEV mode etc disappeared.
So I then decided to go back to 496.76 (again with a clean install of drivers)
to see if the CTDs returned. They haven’t. Basically I have spent all day
in/out/between Blender and running other apps al whilst editing (and saving)
in DEV mode and not a single CTD. I can only assume that somehow when I
installed 496.76 the first time I did not do a clean install and that is what
has caused these issues. I still have DUMP logging on but at this stage, it
appears OK for me now. Check your NVIDIA drivers - reinstall and select the
option to perform a clean install

Let me just check first how we can proceed to comply with GDPR regulations.
I’ll review this subject internally and post a dedicated article.

My CTDs have returned so I had a brief reprieve. Have forwarded a dump to
@FlyingRaccoon by way of another thread here
Sorry for the duplicate threading

Just started experiencing this exact issue a few days ago, it seemed to occur
after placing some PaintedLines. And a few weeks ago, I experimented with
Projected Meshes and it also produced similar behavior (I’m now wondering if
both these issues were related somehow?) I sent MSFS support on Zendesk a copy
of my project file, but this issue has completely halted development for me,
so hoping for a response from them soon, or anyone else who may have managed
to fix this issue :frowning:

Hello @TheJoelster4549 These CTD seems to no longer happen on SU8 RC. We’ll
run some additional tests but I invite you to participate to SU8 testing when
it will be opened so you can check for yourself and confirm you no longer
encounter those crashes. Regards, Sylvain

Hello! I seem to have eliminated the crashes by recreating the project and
manually copying and pasting the XML files into the new project, excluding the
parking spots and taxiways. If I do encounter those issues again though when
adding the taxiways back, I will wait for SU8. Thanks!