Sim freezes when loading, around 60% (with 3rd party content)

Hi. Personally, I was unable to recreate this issue in any of our products
however, a significant number of PC customers reported the sim freeze during
loading, with 3rd party products installed. It seems like most of these
products were obtained from the in-game Marketplace (not all though). Hardware
specs did not seem to matter however users in most reports used
rtx2060/rtx2060S/rtx2070 GPU series. Here are some comments:

Set Departure-Moscow, click “fly” and the loading screen freezes until I end
the program in task manager (0% CPU). Same thing happens with FSDT’s
Switzerland Mesh, also purchased in-sim marketplace. From what I can gather
on the FSDT forum, this is a problem with SU5 and the in-sim marketplace,
because people are able to get Switzerland Mesh to run when they have a
version purchased directly from FSDT even though it’s supposedly exactly the
same except for the installation file/folder structure, suggesting there
could be a file/folder conflict or something like that?

freezing on my end (at about 60% load) when loading chicago landmarks…

I tried several times launch flight from there since the new update, and the
game didn’t respond…what could be the problem?

Actually my loading screen stops and never ever move again

Mine is bought from in-game Marketplace and behaves exactly the same:
freezes at 60% loading.

A friend bought this Landmark in-game. It does not start. Deleting and
reloading didn’t help. I threw my version to him. With the version from the
simmarket, Moscow was launched.

After the last update of the simulator, 1,18,15,0 causes the simulator to

Exhibiting will appear somewhere over the center of Moscow in the air. The
simulator starts loading the location and freezes somewhere by 60%.

I can also confirm that after SU5, Moscow and Chicago Landmarks freeze my
sim halfway loading.

I can confirm Moscow Landmarks freezes my sim at 50% load as well after SU5.
Looking forward to fix, thank you.

i bought the scenery in the msfs marketplace. Unfortunately the sim freezes
if i try to set up a flight in one of the seattle airports. Do you know if
this is due to the latest sim-update ?

I have every Drzewiecki product for MSFS minus the Europe products, and
noticed that I couldn’t even load into Chicago. My game would freeze.

Getting CTD with addons installed after SU5.Remvoed and the CTD went away.

Same issue here…Moscow landmark freeze…it seems to be a bug with other
products bought on official fs marketplace…when bought from orbx central
for example they go in community folder and the things go well…I have
written to orbx …to microsoft and now here…there is a workaround…start
from a near airport…after that exit and load a flight in Moscow (in the
air)…the sims load correctly

Somewhat related. I was helping debug an airport addon, and the materials used
for aprons was causing a CTD. I also got the CTD. I reworked the folders and
XMLs to insure there were no problems with re-used texture or material names.
No more CTDs with my computer either in DevMode or when placed in the
Community folder. Everything displayed properly. The developer however could
never shake the CTDs with my ‘corrections’, even after insuring there were no
addons in his Community folder. I’m now suspecting many of the CTDs are system
related. Either corrupted Windows installations, MSFS installations, or
hardware faults. Maybe I won the hardware lottery, but my system is 3 years
old and Windows 10 updated frequently as directed. Truly a mystery.

Another customer:

Based on my research, the freezing issue when loading into the scenery is
probably a MS Marketplace issue. I was not having this issue a couple weeks
back, but it started with Chicago only. Now I am having it in Seattle as
well after this week’s market update. Uninstalling from the content manager
is fixing the issue. Reinstalling the scenery without closing the sim and
loading into the scenery works, but the moment you exit the sim, and restart
it from the desktop and try to load in again in the area of the scenery it
freezes at about 60%.

The same happens here with the Marketplace scenery. The same scenery in the
community folder does not freeze the MSFS.

(…) I have Chicago and can fly into it without any problems. I tried today
to start a flight and my loading screen froze at a little over 50% I would
say maybe 60%. I am trying of spawn at gate G14 in KORD with the Aerosoft
CRJ700. I have both your Chicago landmarks and FSDreamteam KORD from the
marketplace. I uninstalled your scenery and was able to load into airport
with KORD. I then uninstalled KORD, and installed your scenery and was able
to load in without a problem too. Finally I installed KORD again and loaded
in with your scenery. Seemed the problem was solved. I shut down my
simulator and rebooted it and tried to load in after a restart, but it was
freezing again. Not sure what’s causing it but it may be a conflict between
the two. I tried reordering them in content.cfg but that had no effect
either. I then did the opposite and uninstalled KORD first and had the
freezing issue when I tried loading in. So I restarted my sim so that the
content.cfg and any other remnant of KORD would be removed. When I tried to
load in I encountered the same freezing issue. My only thought is that for
the MS Marketplace version, something is happening upon restarting the sim
that is maybe corrupting something in one of the files, which leads to the
issue with your scenery. This could maybe also explain the issue with
Moscow. (…)

Of course you’re right that problems started with SU5, but the reason why
some users have them and some don’t is because it only affects to those
having the MS Marketplace version, not the Community version (…).

I can only confirm all these scenery crashes are caused by something related
to how the encrypted Marketplace is loaded in the sim ( and it has been
introduced since SU5 ). The same, exact, scenery, when installed in its
unencrypted version in the Community folder, works just fine. With “same,
exact, scenery”, I mean the package in the EXPORT.ZIP file generated by the
export process, which is being sent to the Marketplace team for release, which
works perfectly fine in the Community folder.

@FlyingRaccoon @SonantAlpaca, it would be great if the Team could comment on
this issue - is this something we need to fix at our end (no idea what), or is
it going to be fixed in the next sim update and we do not need to do anything?
This issue influences sales and should be fixed as soon as possible. Even more
important than jetways :stuck_out_tongue:

Add another victim to the list, Moscow freezes at around 60% after SU5 was

Hello. We were able to reproduce the freeze on the packages you mentioned to
Alyzee and found a fix. The fix will come with SU6. Regards, Sylvain

@FlyingRaccoon Thank you, finally! :slight_smile: You probably meant SU7.

Hello @DrzewieckiDesign, no it’s actually SU6, expected in October. SU7 is for
November. (it’s all in the Roadmap here: [September 16th, 2021 Development
Update - Microsoft Flight
Simulator](September 16th, 2021 Development Update - Microsoft Flight Simulator
update/) )

No I meant SU6 :slight_smile:

Yep, I mixed the WU with SU :smiley:

I get infinite loading times even if I open my project when I’m on the main
menu and I load the airports. MFS takes 50 minutes to load! This is not

I had few users report something like that, but they didn’t give me many
details. This weekend one helped with testing and with my add-ons it was a
freeze at loading. Nothing in the community apart from my add-ons, but some
Marketplace content, including Moscow landmarks. After removing marketplace
content all worked fine. Sadly his files got corrupted and he was fed up with
repairing them, so we didn’t conclude which mods conflict with each other.

As I’ve said, I don’t think it’s a problem of packages conflicting with each
other or packages doing anything wrong. I’m fairly sure the issue is related
to the very fact they are encrypted, indicating something wrong is
happening in the decryption process because:

  • The same, exact, package, placed in the Community folder in its unencrypted version, works perfectly fine.
  • The same encrypted package which was on sale before SU5, started to freeze only after SU5 came out.
  • The same encrypted package that freezes on the PC, seems to work on the Xbox.

The last two points, seems to indicate the problem is happening at the
decryption stage, and only in the PC version of the sim, post-SU5.

I’m not saying it is conflict per se. Just adding 2 cents from my users. I’m
way too stupid to figure it out myself :wink: Don’t know if it was mentioned, but
load freeze happens for my users on specific airports (different for every
user) that have nothing to do with any of their installed addons.

Add Okavango to that list. I’ve gotten reports from some customers describing
this exact behaviour.