'toto' text appearing repeatedly in Simconnect Diagnostic Output window

SINCE AAU02 ‘toto’ text appearing repeatedly in Simconnect Diagnostic Output
window This means I find it impossible to see the ACTUAL diagnostics !! SURELY
Asobo have one “Quality before release ‘Test’” that checks Simconnect ?? Any
chance of a ‘HOTFIX’ release anytime soon?

Hi @Ragged_Ray, SURELY you realise that AAU2 is currently in flighting, which
is a beta phase which we use precisely to catch that kind of errors (amongst
others). If this bug prevents you from working on your add-on, please feel
free to revert to the current public version. That being said, I tried to
reproduce the issue you describe on my home computer with the Simvar Watcher
(from the SDK) and got the following output:

Can you be slightly more
specific and tell us which SimConnect functions you are currently using that
may trigger this odd behavior? Best regards, Eric / Asobo EDIT: may I ask why
you decided to post this question under the FX category?

FX Category because wasn’t any more appropriate categories! This happens with EMPTY Community folder BEFORE ANY sim connect comms have been
opened.2023-05-13 (3).png

Hi @Ragged_Ray, I could be wrong but I would have thought
/spaces/13/simconnect.html was more appropriate.
Can you specify when this text starts appearing? Is it as soon as the
SimConnect Diagnostic Output window appears or while the sim is loading? I see
in your last post that you’ve reached the main menu - can you tell us which
aircraft is selected in the hangar? Best regards, Eric / Asobo

Roger on Category. Couldn’t see it on first look !! Yes. Text appears BEFORE
main menu appears but not as soon as Simconnect Diagnostic Output window does.
Loading ‘something’ is happening, then ‘toto’ starts appearing over and over.
Hangered aircraft is Airbus A320 Neo - Not sure it’s the aircrafts fault? Were
you running AAU02 ( ) with simvar watcher when you failed to re-
create the problem ?? Thanks in advance

@Ragged_Ray, Yes I tried with both the Steam and Store versions and couldn’t
reproduce the issue. I don’t think any of my colleagues could reproduce it
either. On top of this we couldn’t find any output of “to” or “toto” in this
part of the code. Would it be possible that an external EXE is running on your
machine and somehow detects the window and steals its standard output? Is
there anything in your EXE.xml? Best regards, Eric / Asobo

Where to find this “EXE.xml” file ??

Would it be possible that an external EXE is running on your machine and
somehow detects the window and steals its standard output? Is there anything
in your EXE.xml? It is NOT stealing simconnect’s output IT IS adding to it

@Ragged_Ray, If it exists the “EXE.xml” file should be in the same folder as
your “SimConnect.ini” file (the one you use to enable the Simconnect
Diagnostic Output). “Stealing the standard output” means that a process that
does not own a window manages to output something to the said window’s
standard output, making you believe it actually comes from the application
that owns the window. It is different to “stealing the output”. Do you know if
anyone else is suffering from the issue you reported? Maybe other devs here
who are trying the AAU2 beta could share their experience on this? As of now
nobody managed to reproduce this behaviour in the office. Best regards, Eric /
Asobo Note: there’s no need to use capital letters to emphasize what you are
trying to say.

Understand no caps necessary! simconnect.ini file on my machine is in
No EXE.xml file can be found? Yes, understand about stealing the standard
output. No, unfortunately I don’t know of anyone else who is having this
problem. It seems I am the only one? What else can I look for / send you?
Thanks in advance.

@Ragged_Ray, If you do not have any EXE.xml then it probably means that no EXE
is launched when the sim itself starts (this file is usually edited by add-on
installers). Unfortunately we are a bit clueless in such cases. Maybe a list
of all processes that run on your machine when the bug happens could help. You
can get it by following these steps: 1. Open a command prompt (cmd.exe) 2.
Enter the following command (without quotes) : “tasklist /FO csv > Running-
Process-List.csv” 3. This will create a file named “Running-Process-List.csv”
in your current folder. 4. Send us this file (it would be more secure to send
it as a private response!) Maybe you are not the only person affected by the
issue - it may be that it is triggered by some combination of settings that we
do not have on our end (although I really don’t see what could cause that at
the moment). Best regards, Eric / Asobo

Here is Running-Process-List.csv renamed Running-Process-List.txt It is still
a csv file I couldn’t find anything strange about about the running processes
either? Thanks

Any special programmable controllers plugged in? (Try with your inputs
unplugged?) Can you also paste the contents of your SimConnect.ini? I’d also
try setting OutputDebugString=1 then use
and see if the output shows there too.

@EPellissier Not sure this has any bearing on
SimConnect console output, but worth noting that several in-game assets do
include “toto”:

  • Packages\fs-base-ui\html_ui\Templates\FlightListItem\FlightListItem.html
  • Packages\fs-base-ui\html_ui\Templates\MarketplaceComponents\Views\CreatorPreview.html
  • Packages\fs-base-ui\html_ui\Templates\WidgetMenuButton\WidgetMenuButton.html

[SimConnect] ;; Set the level of text communication to be provided to the
console, debug string, or log file ;; level = {Verbose, Normal, Warning,
Error, Off}, default = Off level =verbose ;; Open a command line debug window
to display server to client ;; console = {1 (on), 0 (off)} , default = Off
console =1 ;; Use std console instead of dedicated one ;;
RedirectStdOutToConsole = {1 (on), 0 (off)} , default = Off
RedirectStdOutToConsole =1 ;; Sends the output text to the Platform SDK
OutputDebugString. Refer to MSDN documentation for more ;; OutputDebugString =
{1 (on), 0 (off)} , default = Off OutputDebugString =1 ;; file = {path},
optional %03u for incremental naming , default = not writing to file ;;
important: the target folder needs to exist, and not to be protected file
=D:\Temp\DGSLOGDIR\SimConnect\simconnect%03u.log ;; incremental naming
parameters ;; The index of the first log file. Subsequent log files will have
the index number incremented by one. file_next_index =60

No special programmable controllers plugged in! I tried DbgView64 but cannot
see any ‘toto’ text in the output? I am quite sure I do not access the 3
packages you mentioned i.e.

  • Packages\fs-base-ui\html_ui\Templates\FlightListItem\FlightListItem.html
  • Packages\fs-base-ui\html_ui\Templates\MarketplaceComponents\Views\CreatorPreview.html
  • Packages\fs-base-ui\html_ui\Templates\WidgetMenuButton\WidgetMenuButton.html

But I will check further tomorrow

Many thanks in advance.

I hope we can solve this asap :slight_smile:

Thankyou to the guys/girls at Asobo. The ‘toto’ text has stopped appearing (
in Simconnect Diagnostics Output window ) with release ( AAU02 )
Ghosts in the machine, I guess, as you couldn’t find where the error was