Lakes added over large area result in high load time and terrain issues

After the latest sim update, I have been seeing long load times when loading into a flight within the coverage area of my Alaska Lakes addon.

Without the package installed, I can load into the flight in around 18 seconds, but with the pack installed, loading goes to around 80% and then slowly creeps up over roughly 5 minutes.

I have stripped the pack down to just water polys, removing any excludes or terraforming to rule them out as part of the problem. However, the load times are still high and there are a lot of terrain issues going on in the vicinity, which disappear when I deactivate the package.

Some of there terrain issues have been around for a while, and I always just thought it had to do with the mesh in the area, never putting two and two together until recently. Though, even though they have been around for a while, they have definitely gotten much worse after the last sim update.

Pack enabled

Pack disabled

I am under the assumption here that these issues could be due to the rather large coverage area and breaking up the pack may help, but I’m not sure if this matters as it did in FSX - where all of this would have been split along their QMID grid squares?

What is the proper way to handle large coverage areas now?

This area has had terrain issues in the past when dealing with this same addon, so maybe there is a connection somewhere? Though, this exact issue seems to no longer occur, but that may just be due to me removing 90% of the water flattens I had at the time. Terrain spikes around added water features

I have attached the full project and latest build to this post for anyone to debug and make suggestions. (2.3 MB)

My load time, after adding to the Community with no other addons, is relatively quick… maybe 30 seconds
Can you recommend a starting airport to display anomalies?

I can get loaded in in 18 seconds at 8AK5 without the pack, but at least 5 minutes with it.
Look at the Denali range to the West/Northwest of the airport. Most of it will be missing as in the photo as well as around some of the lakes just before the mountains.

I remembered that you can do a box select in the sim to select multiple items, so that made debugging a bit easier.

I deleted around 3/4 of the lakes just keeping the ones in Denali and a somewhat wide area around 8AK5. Still a decently large coverage area.

After compiling and reloading the sim, load times are back down and the terrain issues seem to be gone. So it’s definitely to do with how the sim handles loading large coverage areas now.

I guess I’m going to have to figure out how to split of the package into smaller chunks without it being a data management nightmare.

Edit: Some more info: if I disable “Enable Water Flattening” under Options > Ground, the terrain issues all go away as well.

I reproduced the long load time. Your package in Community, and starting at 8AK5. 5:32 load time. I tried different graphics settings, and no difference. CPU fan goes crazy when trying to start there.
Without the package in Community, I get a load time of 0:22.
I didn’t have the anomalies you had. The mountains to the west were OK.

By chance, do you have Enable Water Flattening disabled as I mentioned above?

Which pack is this you are referring to Id like to test it out as well. Thanks

It’s an attached download at the bottom of my OP.

please forgive me but what is your OP, Im not up to date with all of the jargon

It’s the first post in this thread

lol ok thanks and sorry

1 Like

Ok, I spent the last hour or so carefully breaking the coverage area into 6 smaller chunks. Unfortunately it doesn’t seem to have made a difference. I’m still seeing a 5+ minute load time and major terrain glitches if I have Enable Water Flattening turned on (default setting).

I disabled the larger of the 6 chunks which was near the center of the coverage area. That got the load time down to ~2:20 and at a quick glance-over, I’m not seeing any terrain issues.

That said, it seems like the loading time is cumulative depending on the number of water polys present in the package, not just in a BGL chunk. Terrain issues also seem to be tied into the automatic water flattening, but only if a certain number of water polys are present in an area.

Honestly as long as any mod make my game more enjoyable I dont mind waiting for the game to load as long as its not a frame killer.

Yeah, it’s just inconvenient. And the load time is definitely because something has changed in the latest update with how water polygons/flattening are handled. Because prior to the last update, there was no noticeable impact to load times.

I’m more concerned about the terrain issues as I cant seem to fix them no matter what I try. Even breaking up the package as I mentioned above had no effect. But if I turn off the water flattening option in the dev menu or remove the package it goes away.

Unless my sim is just bugged out, but the load time was at least reproduceable by someone but myself.

@Boris @FlyingRaccoon
I know y’all have to keep track of like 500 active topics at once, but is there any chance that any of this info has been passed along to the development team?

I don’t think this is something I can fix, or if I can, I do not know the correct method as everything I have tried has made no difference.

My issue may or may not be linked to this issue as well:

Sorry for the tags, but I’d appreciate any further info you can give me on it, as I have been getting a steady stream of support messages with users thinking my addons are all broke or poorly optimized since SU13 came out. Especially the payware, which hurts me the most.

I have done all I can do on my end to inform users of the issue, but it’s proving to not matter much (people don’t read).

Would be nice to know if it is or isn’t something I can be actively fixing.

Thanks for sifting through these issues day after day!

Unfortunately, we don’t see any progress on this topic, even I had to give up in continuing to create customized scenarios by modifying large areas (geographical grid of 1°x 1°) with the presence of water bodies in BGL format.
The difficulty consists in the loading times of the customized scenario which is frighteningly very high (of the order of a few tens of minutes), when up to a few thousand water bodies are present in the BGL scenario (from an XML).

It did get marked as “reviewing” here a week or so back, so hopefully that means it’s at least being looked into.

Hello @Rotornut44

My apologies for the late reply.
I was able to reproduce the issue when your package is loaded from community so I will log this issue.
Not sure when someone will be able to investigate but I’ll come back to you as soon as we make progress on this.