SDK BUG: Only remove runways is marked and SDK deletes everything (taxiways and aprons)

Hello there!

I have a big problem since last year regarding the SDK and that I haven’t been able to figure it out.
I’m trying to make a SBGL Improvement (over the original Asobo’s SBGL), as you can already see on Just like as many improvements out there on Asobo’s sceneries (EHAM, OMDB etc).

Just a couple of textures placed over the default ones to make it look better and more realistic and removing also the terrain problems that exist. The problem is when I try to make a runway. As you can see on the right, the ONLY delete command made was to delete the runways. Not the taxiways, not the apron. Anything but the runways. Just for me to make better runways with precise touchdown zone and aiming, which ASOBO’s default are not by far.

This problem happens just when I add an apron with some material lib imported from photoshop (like gate number etc). When I add that, the SDK deletes everything just like the picture. When I delete these custom material lib aprons from the scenery, they all come back again. Why? Is there any way to turn arround this problem/add custom material libs in another way?

Could anyone please try to explain me why all the taxiways are deleted when I try to make a runway? I didn’t command that. Thanks a lot!

Hi, I curious about the issue so tried a sample project in the area,
aprons and taxiway still there when

  • using deleteAllRunway
  • adding a runway
  • adding a custom material to the Runway
  • adding an apron
  • adding a custom material to the apron

Could be that your materials aren’t set up properly?
Did you try to zoom in/out to make the airport textures reloading?

Here is the project with the materials (1.9 MB)

1 Like

Hi mate!

Thats the problem. The SDK has no logic. It’s broken and bugged. It gets in the way everytime and that’s why so many talented people resign while making sceneries.

Now this happened. I have already resigned to make runway from scratch. But it’s bugged. 10 hours ago I closed the SDK with the taxiways and aprons appearing. When we go to work again, this happens. A shame.


And I sent my project to a scenarist friend of mine and the project was like that in his PC, so it’s not a computer config thing.

hey man, i know your frustration with sdk i’ve been through it and still pass SBGR and SBCT.
I’ll try to pass on some annoying bugs that I taught myself how to fix.
1- if you work in Dx12 try to change to DX 11 because there is an annoying bug in DX12 of drone camera lod or camera developer that disappears the whole ground when we zoom. Take your drone or camera developer and go up until the scenery is very small seen from above. then drop back down to the airport and the ground will reappear. (follows image)

2- never forget to place your personalized materials in the material editor within your project so that you avoid not saving the content created recently.

3- always save your scenario before closing or compiling your project. Nowadays we get a warning if you want to save the project, but in the past that message didn’t appear and we lost everything if we didn’t save the scenario. It’s a hard thing to happen but it happens.
Here everything worked normally because a long time ago I had already made improvements in SBGL for some friends who asked me.

But if in any case it doesn’t solve it and you need some help, you can count on me on discord so we can try to see what’s going on with your SDK.
I’m currently finalizing SBGR for paid launch, if my account is approved with 02 years of waiting hehehe.

1 Like

Hey mate @Jamilzeira , tks so much for your help.
We can talk via Discord if you want, im losing 3-4 hours of work just trying to lauch my project on SDK. If you want, add me on Discord: stefano7378

I will try to finish SBGL until the end of September if all goes right.

Tks so much

Hello @klokous

If you are able to send us the project sources that produce this issue, we will try to trace where it comes from.


Hi Sylvain, thanks for your answer and desire to help!

The project details and it’s issue is detailed below:

Device: Windows 11
SDK Version: 0.21.1 (latest version)
MSFS version - latest version (Microsoft Version, not Steam)
Running on DX11,
Airport: SBGL - Galeão Airport, Brazil
What is it? A improvement project OVER the default scenery

I’m not starting this project from scratch, I don’t want it. That’s why my delete command is empty, I’m not selecting to delete anything default. I’m editing the default objects and textures that can be edited, not creating from scratch. I was able to make it until now. I placed custom taxilines over default ones and it was fine. I changed the runway textures, edited the markings using painted lines and it was fine. I removed default objecs such as light poles placed wrongly, stairs placed wrongly. I changed grass textures and it was fine. I added dirty decals and it was fine. I did a great portion of the scenery well just editing it. Check on the the freeware project to see what was done until now with more details. But right now I’m literally stuck due to SDK problems, bugs and limitations.

I had this problem when I tried to add runways from scratch. My delete command was set to delete RUNWAYS ONLY, but when I added APRONS with CUSTOM MATERIAL LIBS (markings, aiming points, runway number, etc), all the rest of the scenery (taxiways and aprons) got DELETED like my delete command was set to delete them, while it was not. But no problem, I can overcome this BUG and just edit the runways with a lot more work, but I can do that and overcome the problem.

I did and I’m satisfied now. But now I’m stucked again with the SAME PROBLEM. I have some APRONS with CUSTOM MATERIAL LIBS around my scenery that worked, all of them in the taxiways, before entering the apron (txy indications etc). But when I try to add a APRON with CUSTOM MATERIAL LIB INSIDE the MAIN APRON of the airport, ALL THE GROUND TEXTURE regarding APRON and TAXIWAYS got DELETED like my delete command was set to delete them. See the image below:

NOTE: If you delete all the Y1’s markings inside the apron, build all and reload the scenery, the ground will be there. You can add as many markings you want over the apron. The ground textures will not disappear instantly. You will place everything and you will think it’s fine. But when you build all and reload again, the ground is gone again. Please help me. I want to make my hometown airport.

How will I add gate numbers?
How will I add taxiway indications?
How will I edit a bad default scenery and turn it into good if the software does not make what I’m telling it to do?

1 year ago I had the same problem at SBGL and gave up. I’m here again just trying to finish what I started. In 1 year I didn’t notice any difference on the SDK. 2 developers tried to help me without success regarding this BUG. I’m asking for a fix, please.

As I can’t attach 2 images in the same post (???), here goes the another

Where can I send you the project for you to analyze better my issue?
Tks in advance!

See here how to send private content: How to report a bug or crash

Done, thanks so much for your help

Hello @klokous,

The package you sent us has some errors:

  • Missing title
  • Two BGL files, and one of them is empty
  • Your material textures are not located in the ‘texture’ folder as specified in the docs:

    Please remember to clean and build your project after addressing these issues.

Finally, you have two options:
Option 1: Delete your current materials and create new ones using the correct images path.
Option 2 (much easier): Open every .material file in your materialLib and update the line:
<Texture FileName="mytexture.png" ..."/>
<Texture FileName="texture/mytexture.png" ..."/>
I’ve tested by addressing all these issues, and the apron now displays correctly.


1 Like

Hey Boris, Thank you so much! I Will test this in a moment!
What do you recommend To do with the other bgl file? Use ir or delete it?


I’m not getting the texture thing. I make the texture on PhotoShop and then I export to the vapp-sbgl-galeao\PackageSources\MaterialLibs\gigmatlib folder and then I go to the SDK and import them from this folder. I did this way in another scenery that I made from scratch and it worked.

I opened every .material file in my vapp-sbgl-galeao\PackageSources\MaterialLibs\gigmatlib folder and update the line <Texture FileName=“APRON.png” …“/> to <Texture FileName=“texture/APRON.png” …”/>. When I opened the scenery, all of them became pink textures. What is wrong? I have to create a “textures” folder? Could you send my project that you edited for me to see?

Tks so much

I made a screenshot on my message above that explains it all :

"create a "textures" folder, and then copy the necessary textures there"
It means that you should have :
vapp-sbgl-galeao\PackageSources\MaterialLibs\gigmatlib\texture\mytexture.png etc…


Hey @Boris , thank you!

I make all the procedure regarding the material libs and the texture folder that you showed me.


The aprons with custom material libs are appearing, but the ground textures not yet.

Thats why I say, this bug is not a simple thing. If you solved this problem, please I ask you to send the project with the bug fixed, it’s the best way. If you are able, of course.

Thank you

I made every step you said.

Title :heavy_check_mark:
One BGL not used deleted :heavy_check_mark:
Create texture folder and change the .material :heavy_check_mark:
0 errors during build all :heavy_check_mark:

Still like this

Today I spent the whole evening with a friend who is a much experienced developer and scenery maker trying to figure out the problem. We worked pretty much on hierarchy problems, we created another project from scratch and tried again with another hierarchy to check if the issue persists. We organized everything correctly in the folders and etc. The issue reported above remais 100% the same without any changes. We tried to work on the textures, trying to reduce/change the resolution without success to solve the problem. Any apron with material lib placed inside the main apron/terminal area of the airport fully delete the whole ground texture of the airport. When we delete them, the ground textures are back.

NOTE: If you delete all the Y1’s markings inside the apron, build all and reload the scenery, the ground will be there. You can add as many markings you want over the apron. The ground textures will not disappear instantly. You will place everything and you will think it’s fine. But when you build all and reload again, the ground is gone again. Please help me. I want to make my hometown airport. To consider the problem solved, you need to build all/build package with the custom textures on the main apron, add the scenery in the community folder and open the simulator again. If the ground textures, in this situation, were there, then the problem is solved. Looking only by the SDK can give an impression that the problem is solved as the ground textures can be there while is not if you build all/build package.

We are almost pretty sure this is a SDK limitation but we are still testing to check more and more. We spend 2 evenings checking but nothing we have tried lead to success.

Thank you for your time and hope that we can fix that!

Hello @klokous

We had a look at the second project you sent us.
We were able to see the markings while still having the default apron being rendered.
Noting by the way that your material library still uses textures that are not in a dedicated “texture” directory.

So that leads us to think there’s a problem with the context.
Are you sure you don’t have any conflicting package in your Community or Official package folder? (a version of the package you are editing in Community for example)
Is there any other project you have that uses the same material library name?